Software Manager Quickly clicks off

Good afternoon.....when I click on Software Manager, it shows that it is downloading the Catalog. Then it flashes the various items such as Editors picks. But it flashes off in a second. I can use Software updater with no problem and Terminal works fine. This problem only started today...I was able to use it yesterday with no problems. Thoughts? Many thanks in advance for your guidance.

As a first step, let's try reinstalling it:

sudo apt install --reinstall gnome-software

Did that....and then attempted to run the software manager. Still quickly clicks off.


sudo killall gnome-software

sudo rm -r ~/.local/share/gnome-software

Then try launching Software store.

Same result....

sudo killall gnome-software
gnome-software: no process found

udo rm -r ~/.local/share/gnome-software
rm: cannot remove '/home/pmm/.local/share/gnome-software': No such file or directory

That just means that Software was not actively running.


rm -rf ~/.cache/gnome-software

That worked! Many thanks Aravisian!


1 Like

Marked thread with solution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.