Software Store Broken

I've been having trouble lately with the Software Store app. Starting about a week or two ago, it would hang (endless 'working' mouse icon) when I selected either the 'Installed' or 'Updates' tab. After reading some forum threads, I tried the following at the terminal:

'sudo apt install --reinstall gnome-software'

Now the software store doesn't even start. I need some help before digging this hole any deeper.

What happens if you launch gnome-software from terminal? Does the terminal print any output?

Typing 'gnome-software' [enter] at terminal prompt gets a blinking cursor with no output... like it's hung?

Try this version of the command...

sudo apt install -f --reinstall gnome-software

Maybe forcing installation of dependency files will get this bloody mess sorted out.

Ohhhh, and, please restart the computer after running this command. Then once back in, we will see if you can get an update to your system using the following command...

sudo apt-get update

1 Like

OK, that seems to have fixed the software store. When I open the app, it now starts promptly, and when I click the 'Installed' and 'Updates' tabs, they load quickly and seem to be working fine.

When I ran the 'apt-get update' command in terminal, this is what I got...
"Reading package lists... Done
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)"

One other detail... the software updater app ran automatically on reboot, and was completed before I ran that last command. When I select 'Updates' tab in software store, it says 'Software is up to date' and references the reboot time as the time last checked.

I edited my post to add the SUDO command, oops. :pleading_face:

If my solution helped fix this problem, please mark it as solved. Thanks again Orion. And don't forget, you are stellar! :star2:

   StarTreker

yoda
Your Tech Support Guru

1 Like

The apt update command requires sudo privileges.

1 Like