Software Store (gnome-software) buggy

I really do not use it, but while looking for answers to another users issue today:

When I clicked "installed" tab in gnome-software, it loaded for about 7 full minutes. Finally, it stopped loading to reveal only a blank page.

I decided to perform something I recommend to others having issues with gnome-software and that worked for them:

sudo apt install --reinstall gnome-software

My terminal replied with:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reinstallation of gnome-software is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

EDIT: I removed snapd from the system (because apparently, I forgot to!) and now opening software store > installed loads the full list immediately-- though I am not sure if that is a solution or random chance.

3 Likes

Basically, my problem with gnome software is that it's very slow. When I search for smthg it takes forever, and it just fails. When I try to see which software I have installed, but it takes too long. I could just $sudo apt list.

Synaptic Package Manager is much more responsive and useful in my opinion.

Install Synaptic Package Manager:
$sudo apt-get install synaptic
Remove Synaptic Package Manager:
$sudo apt-get remove synaptic

I do have a problem, in the Zorin Menu there is a software shortcut button, I already uninstalled Gnome-Software.

1 Like

Yes. I am also confuse when I uninstalled vmPlayer and he is still in menu.
I get information I cannot install vmware workstation if not uninstall vmPlayer. Both are in menu.

here some information.

I've had this from day 1... Saying '1' next to Installed...
I tried the reinstall thing..