Software store not working properly

Just managed to install Zorin OS, but as the title says, the Software store wont work. There are two problems:

  1. When I search for apps, it just shows an endless loading screen, and only sometimes it shows the app I searched for.
  2. Apps won’t install; It only shows “Installing 0%” and nothing happens.

I tried the below workarounds to no avail:

1. sudo apt install —reinstall gnome-software
2. sudo apt install -f —reinstall gnome-software

Restart, then

sudo apt-get update

Any solutions?

Have you tried removing the contents of ~/.cache/gnome-software?

1 Like

How do I do that? Is there any specific command for it?

However you want to. In File Manager GUI or in terminal with

rm -rf ~/.cache/gnome-software

Using the File Manager may be easier, preventing the use of the dreaded rm -rf command.

Didn’t work :upside_down_face:

In terminal, please run:

sudo apt clean && sudo apt autoremove

sudo apt update && sudo full-upgrade

Test Gnome software. If still no good:

If you launch gnome-software from terminal, does it yield any output that may be a clue?


Thanks, that seemed to have fixed the problem. However, all the apps install except Steam.

sudo apt install steam

Watch the output - relay any errors.


Thanks, I installed Steam. There were no errors.


It seems that all apps will install except games. Is something missing? @Aravisian

I am not sure. Usually... Gnome-Software either works or doesn't work. I've not seen it exclude a certain genre of apps, before.

1 Like

I sure do love your expert acrobatics.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.