Software update error Sep 28, 2021?

Have any of you been getting System Software update errors today? Including telling to do a partial update using the GUI. Tried both Main and HK servers.

Separate terminal update gets you repository error too?

I held off on updates, just in case.

I have been getting short update error messages on my Zorin installation, after an update has already completed earlier in the day, and after launching the Software Center APP. These error message I am talking about are off and on.

Let me boot up my Zorin installation, and check......

1 Like

I think I did a Zorin update a few hours ago too. Maybe we have the same issues too.


I experienced the same as you a few minutes ago. i run this from terminal.
sudo apt-get update && sudo apt-get upgrade -y
after that no problem.


1 Like

From some days i don't have any updates. I have always my system is update.

1 Like

For the record, I was able to booth the computer up just fine, and after being on for a minute, the software update popup came up. So I installed the updates, and updates installed just fine.

I decided to make my very first video for the forum, I filmed booting the Zorin machine up, which includes OS startup sound, that was way too loud, but you guys will enjoy it lol. And I even filmed the entire update process, with a flashing soon to be dead battery symbole, and holding my arm's out, feel the pain Shaolen priest style, all for the footage.

I need to edit it first before I can post it though, and then I will put the link in this thread, and in my very own thread as well, and hope the video will make you guys happy. lol


I just tried it again thrice, 10 minutes apart, using the recommended commands. Still got the issues. I guess I'll wait some more.

30 minutes later: I did the partial update, which includes kernel upgrade to 5.11.0-37-generic and removal of other things. Did a second apt update after reboot and still got the same repository issue. I guess I'll check again tomorrow.


Sometimes update issues can be on server side, so it can take a day or two for them to resolve it.

Here is my video guys. This also marks the first video that I have made with the new Kdenlive update as well.


Music reminds me of RDR2.:joy:

I see cereal bowl! :bowl_with_spoon:


Yes, Youtube Audio Library is very extensive, and they add to it all the time. But I had no patience to go searching forever for a tune, so I just used one that I had downloaded from there a couple months back.

Yes, and you see salad bowl too right below it. Don't worry though, both bowls are clean, as is the silverware. Whenever I eat a salad, that bowl is ready to go. And I like to eat oatmeal out of the smaller bowl stacked on top of it.

What kind of oatmeal I eat I hear you ask? Nothing but the good stuff, Quaker Oats instant oatmeal with fruit flavors, comes in a variety box. Delicious! :yum:

1 Like

Mine does not even show the zorin logo but it's showing my acer predator logo haha.

As for the update errors, i just ran the terminal and wrote sudo apt-get update && sudo apt-get upgrade everything is working fine.


Still got the repository issue. But, I received a small Zorin distributed update today.

Oh well, I guess Zorin may need to check up on the sources?

1 Like

This maybe a stupid idea, and it may not work at all. But I am just trying to help, and make your life better.

Go to software and updates, switch from Main Server, back to your countries server. Let it reload after, restart the computer. Then see if you can update.

I really hope we can help get this fixed for you, cause your awesome Kevin, want you to be happy.

1 Like

No recommendation is stupid.

It was the first thing I did yesterday and today with multiple tries and multiple local servers. Still got the same issues. It's usually those two.

But, I'm still getting sporadic small update requests from the GUI though. Those installed ok.


The updater says it was trying to install 32bit packages, which was the issue, as 64bit is not available. In Focal man, 32bit support has been dropped completely.

1 Like

Thank you for being one of the few to put what distro you have in your profile, it really helps. Cause now that I know you have PRO, my next recommendation is, if some last minute back and fourth's between you and Aravisian can't bring fourth a solution..................

Then go ahead and use your PRO privilege and contact the Zorin team, use the registration number you were provided in email, and then wait for a response, which could take a week just so you know.

But them being developers, are experts. Although, I will say this, Aravisian is proving to me he's becoming an expert everyday, cause that guy likes to learn code like crazy. Ya, I know, he's pretty cool, but so are you hehe.


This may be worthwhile now, as there may be an error in the upload that needs immediate attention.

Sidenote: Pro users get support for the installation, not the rest of their lives... :wink:

1 Like

Awww....shucks. I'm blushing. LOL.

I noticed the i386 and 32 !=29804 and wondered maybe they removed the source and the repository didn't update.

I'll give it a few more days and see. I'm still getting other updates as needed. It's just seeing the error is a bit annoying. LOL.

1 Like

You may check your sources.list, just to be sure. You can compare against @StarTreker if willing to help. I am off to bed.

1 Like