Software updater cannot connect to internet

im using zorin os 17 beta and wanna update to stable but when i launch software updater i get this message...
image
when i put my pc to sleep while updating, it logged me out, after rebooting i installed steam but this issue pops up

Welcome! :smile:

That won't really work :smirk: if the machine is in suspend / sleep mode, there won't be any activity to update.

Do you have internet connectivity; wireless or ethernet?

If you could: post the output of sudo lshw -C network in terminal :+1:

You also might launch Software & Updates and under the "Download From" drop down menu, select Main Server.

Once that is done, try running the updater again or in terminal run

sudo apt update && sudo apt upgrade

That should get everything up to date.

Once that is done, in Software & Updates and under the "Download From" drop down menu, select your previous regional server.
Close Software & Updates once finished.

1 Like

by that i meant, it happened after i accidentally put my pc in sleep mode while updating, since it is pretty common of me turning down the lid whenever i move (lol).
sometimes relogging in crashes gnome and gdm.
yes, i live in india and have a ZTE/NetPlus/Fastway Router. i am gonna swich to jio airfiber, since i live a bit far from the city and only net plus and airtel give wired service, but jio airfiber does not need cables (not sponsered lol). Netplus provides bad quality and their SetUpBox bassically stopped fuctioning since they move their focus when releasing a new one.
anyways, back to the point,
here is the output of sudo lshw -C network

yes, it did tried switching to main server and also the best server,
the output of main server after reloading cache:


i can conform i have wifi since im posting on the same machine.
this is what sudo apt update && sudo apt upgrade gives me:

atharv@atharv-Lenovo-ideapad-320S-14IKB:~$ sudo apt update && sudo apt upgrade
Ign:1 cdrom://Zorin-OS 17 Core Beta 64bit jammy InRelease
Err:2 cdrom://Zorin-OS 17 Core Beta 64bit jammy Release
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Hit:3 http://archive.ubuntu.com/ubuntu jammy InRelease
Hit:4 http://in.archive.ubuntu.com/ubuntu jammy-updates InRelease              
Hit:5 https://repos.azul.com/zing/ubuntu jammy InRelease                       
Hit:6 https://dl.google.com/linux/chrome/deb stable InRelease                  
Hit:7 http://security.ubuntu.com/ubuntu jammy-security InRelease               
Hit:8 http://in.archive.ubuntu.com/ubuntu jammy-backports InRelease            
Hit:9 https://packages.zorinos.com/stable jammy InRelease                      
Hit:10 https://packages.zorinos.com/patches jammy InRelease
Hit:11 https://ppa.launchpadcontent.net/zorinos/apps/ubuntu jammy InRelease
Hit:12 https://packages.zorinos.com/apps jammy InRelease
Hit:13 https://ppa.launchpadcontent.net/zorinos/drivers/ubuntu jammy InRelease
Hit:14 https://ppa.launchpadcontent.net/zorinos/patches/ubuntu jammy InRelease
Hit:15 https://packages.zorinos.com/drivers jammy InRelease
Hit:16 https://ppa.launchpadcontent.net/zorinos/stable/ubuntu jammy InRelease
Reading package lists... Done
E: The repository 'cdrom://Zorin-OS 17 Core Beta 64bit jammy Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'https://repos.azul.com/zing/ubuntu jammy InRelease' doesn't support architecture 'i386'

it all happened after installing steam from apt...

my config of software and updates:






i will be happy to provide more info @Aravisian @PlumpKibbles :slight_smile:

In Software & Updates > Other Software, uncheck the option for CDROM:Zorin ...
That is only for use with you have the LiveUSB plugged in and are using it to repair or install from the installation media.
Any updates that are released after the .iso file may not match the .iso file.

thanks it worked! just one question, when will zorin os 17 education release and what are the additional software shipped with zorin os 17 pro?

also, how do i switch from pipewire to pulseaudio since zorin os says it uses pulse audio server but i see pipewire in background processes @Aravisian

Can you please start a new thread on this issue?
It helps keep issues separate so that the forum is organized, allowing users to find solutions.
Also, I believe other members may be better versed with Pipewire than myself.

this solution not working for me


as you can see here I have this option unchecked and I got same error

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.