(Solved) 4K Display Lag and 60Hz Refresh Issues nVidia 2060

Hello everyone.

I have an Asus G14 laptop (2020) with an nVidia 2060 GPU.

I have just done a clean install of Zorin 16 Core using the nVidia boot/install option.

Problem #1 is that there is no 60Hz display mode listed for my external 4K display. This display works just fine at 60Hz at both 4096x2160 (native for this display) and 3840x2160 in Windows 10 on the same laptop and HDMI cable. Additionally on my Macbook Pro (2017 with Intel IGPU) also displays correctly at 60Hz with the same HDMI cable. So I know the display, cable and laptop are capable of this configuration.

I have attempted to set a custom display mode from bash but this results in a blank display at 60Hz

Problem #2 (and perhaps this should be a different thread) is that with the external 4K display connected using the nVidia 470 (tested) driver the frame-rate of the desktop drops to very, very low, making the desktop unusable. If I switch to the X.Org Nouveau open source driver, this behavior goes away and the desktop perform as expected (albeit it still stuck at 30Hz --- see problem #1).

There are no issues with the laptop onboard display running and working, only with the external 4K display.

I have done some searching and have not seen these issues here on the forum. If anyone has experienced this or have suggestions it would be appreciated! I am really liking Zorin 16 so far and will switch to Pro if I can get this figured out.

~$ xrandr
Screen 0: minimum 320 x 200, current 4096 x 2160, maximum 16384 x 16384
eDP connected (normal left inverted right x axis y axis)
   1920x1080    120.00 +  60.00  
   1680x1050    120.00  
   1280x1024    120.00  
   1440x900     120.00  
   1280x800     120.00  
   1280x720     120.00  
   1024x768     120.00  
   800x600      120.00  
   640x480      120.00  
HDMI-A-0 connected primary 4096x2160+0+0 (normal left inverted right x axis y axis) 941mm x 529mm
   3840x2160     30.00 +  24.00    29.97    23.98  
   4096x2160     30.00    24.00    29.97    23.98* 
   1920x1200     30.00  
   1920x1080    120.00   119.88    60.00    59.94    24.00    23.98  
   1600x1200     30.00  
   1680x1050     30.00  
   1280x1024     30.00  
   1440x900      30.00  
   1280x800      30.00  
   1280x720      60.00    59.94  
   1024x768      30.00  
   800x600       30.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94  

~$ inxi -Fxz
System:    Kernel: 5.11.0-37-generic x86_64 bits: 64 compiler: N/A Desktop: Gnome 3.38.4 Distro: Zorin OS 16 
           base: Ubuntu 20.04 LTS Focal 
Machine:   Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401IV_GA401IV v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: GA401IV v: 1.0 serial: <filter> UEFI: American Megatrends v: GA401IV.219 date: 12/30/2020 
Battery:   ID-1: BAT0 charge: 74.2 Wh condition: 75.3/76.0 Wh (99%) model: ASUSTeK ASUS Battery status: Charging 
           Device-1: hid-20:73:03:2d:3f:0d-battery model: Anker A7721 charge: N/A status: Discharging 
           Device-2: hidpp_battery_0 model: Logitech M720 Triathlon Multi-Device Mouse charge: 55% (should be ignored) 
           status: Discharging 
CPU:       Topology: 8-Core model: AMD Ryzen 9 4900HS with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1 
           L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95819 
           Speed: 1635 MHz min/max: 1400/3000 MHz Core speeds (MHz): 1: 1572 2: 1620 3: 1508 4: 1407 5: 1389 6: 1397 7: 1394 
           8: 1214 9: 1397 10: 1398 11: 1330 12: 1279 13: 1397 14: 1397 15: 1398 16: 1397 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2060] driver: nouveau v: kernel bus ID: 01:00.0 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 04:00.0 
           Display: x11 server: X.Org 1.20.11 driver: amdgpu,ati,nvidia unloaded: fbdev,modesetting,nouveau,vesa tty: N/A 
           OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.11.0-37-generic LLVM 12.0.0) v: 4.6 Mesa 21.0.3 direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-2: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus ID: 04:00.1 
           Device-3: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK driver: N/A 
           bus ID: 04:00.5 
           Device-4: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 
           Sound Server: ALSA v: k5.11.0-37-generic 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 9.58 GiB (0.5%) 
           ID-1: /dev/nvme0n1 model: PCIe SSD size: 1.82 TiB 
Partition: ID-1: / size: 235.13 GiB used: 9.55 GiB (4.1%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 39.2 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2500 
           GPU: device: nouveau temp: N/A device: amdgpu temp: 35 C 
Info:      Processes: 350 Uptime: 7m Memory: 38.62 GiB used: 2.42 GiB (6.3%) Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.17 inxi: 3.0.38 

Ohhhhhh, you don't want to be using the TESTED driver, I had nothing but issues with that driver, not being able to utilize my GPU at all. You want to use 470 PROPRIETARY. Is that driver version not available in your Additional Drivers list? If not, were going to have to add it.

Did you try to install nvidia driver from the site ? Might worth a try.

The only problem i have (gtx 1070 user here) is that i cant change resolution in zorin. I am forced to use 3840x2160. If i change it to 1080p i get a black screen and cant do anything. In games however i can change it to whatever i want. That said, if i want to change the refresh rate i can only select auto or 60hz. I have a g-sync monitor in my laptop and i really thought my display could handle 144hz but i am not sure.

OK thanks, am going to try the other 470 one (without the TESTED label). This is what came up by default (top driver)... I switched to the Nouveau driver and it solved the lag issue but would prefer the nVidia driver.

OK so good news switched to the 470 proprietary driver (non-tested) and no lag issues, so that's a win. Still stuck at 30Hz though with either 4K res (4096 or 3840).

Going to swap the HDMI cable, xrandr still reports no 60Hz though. Maybe cable?

Maybe. What are your cable specs?
https://www.hdmi.org/spec/hdmi1_4b

Only supports 4k up to 30hz.
If not your cable, always be sure to fully update and upgrade after a fresh installation of the OS.

sudo apt update && sudo apt full-upgrade

1 Like

It is possible to be a cable issue. But there is an easy way to tell. Look at the writing on the cable. You want to see it say stuff like supports 4K 60 or UHD 60.

1 Like

Swapped cable and initially no joy, but tried to set custom resolution again and BOOM, it worked, even though the display mode is not listed. Swapped back the original cable and that worked as well.

~$ xrandr --output HDMI-A-0 --mode 4096x2160 --rate 60

HDMI-A-0 connected primary 4096x2160+0+0 (normal left inverted right x axis y axis) 941mm x 529mm

No idea why it didn't work before, maybe it was the junk tested driver.

Display Settings still shows 30Hz but suspect this is because I haven't added the display mode. It's def running at 60Hz now because it's smooth and colors are correct now.

2021-10-09_02-16

Thanks for the help all, I think this can be attributed to the junk "tested" driver that the install defaulted to.

2 Likes

I'm so happy that we were able to help you fix this! And... Welcome to Zorin OS 16, and to the Zorin family.

  StarTreker

yoda
Your Tech Support Guru

1 Like