Solved: auto-rotate on touchscreen tablet PC now working - use xorg instead of wayland

Credit:

It's all working after I switched to xorg from the gear icon on the login screen.
It wasn't working in Wayland, which was the default.
From what I read on the internet, it appears there's a bug in Wayland, which prevents auto rotation of the screen.

My touchscreen tablet PC is a Panasonic FZ-G1 MkIII ToughPad.

I switched from Wayland to xorg at the login screen, via the cogwheel at the bottom right hand corner.

1 Like

Solved as above in the question itself. Copying here to be able to mark a solved solution and flag the question as having a confirmed solution. Thank you.

Credit:

ubuntuforums.org

Auto rotation worked in live session but not after full installation [SOLVED]

I have first tested Ubuntu in live USB session for auto screen rotation and found it working. Both in landscape & portrait modes. But after full installation, it's not working. My machine is Lenovo Yoga 520 convertible. Can you please help?

It's all working after I switched to xorg from the gear icon on the login screen.
It wasn't working in Wayland, which was the default.
From what I read on the internet, it appears there's a bug in Wayland, which prevents auto rotation of the screen.

My touchscreen tablet PC is a Panasonic FZ-G1 MkIII ToughPad.

I switched from Wayland to xorg at the login screen, via the cogwheel at the bottom right hand corner.