[SOLVED] Can't Change Custom Cursor Size - Zorin OS 16.2 Core

I use Zorin OS 16.2 Core on a 2018 HP Gaming Pavilion Laptop. Recently, I got the DMZ-White cursors working on my install. They look great! But because they're custom cursors, I can't customise them as much. For example, I would like to make my cursor larger for me to see. But when I set the pointer size to be larger in my settings, it does nothing. It will change the size of Adwaita, but not DMZ. I'll attach a quick video of what happens.

I didn't know if this should go in the help/support section or customisation, would be nice if it could be in two categories! :laughing:

It will not allow me to see your video. But I think the command below will solve your problem.

24: Default
32: Medium
48: Large
64: Larger
96: Largest

You can change the cursor size from these options through the following command:

gsettings set org.gnome.desktop.interface cursor-size [sizeInPixels]

It says in the article to reboot for it to take effect so I advise doing that. (Even though it works for me immediately)

I followed the guide (via both the settings app and command line) and my cursor is still small after restarting.

The video showed me changing the cursor size in Zorin settings and the cursor staying at the Default.

Thanks for the help!

Edit: I posted it to YouTube for it to show here:

1 Like
gsettings set org.gnome.desktop.interface cursor-size 96

Run that command exactly as is. I do not use the default cursor and that works for me. (It is going to make it giant for the moment if it works so dont freak out lol)

If that does not work I use the Light cursors of this and it is absolutely working for me. If you do not mind Windows like cursors that is. I have a bit of nostalgia for them lol

What I get when I run the command

What I get... the cursor is still small, and I restarted. I did it twice with different sizes too.

I just tried with DMZ White myself and it works. That is so weird

Idk, did we get it from the same source?
I got it from Gnome-look

I used the deb package. Maybe try that?

sudo apt install dmz-cursor-theme

Delete the ones you have installed first and give that a shot. I would not think it would make a difference but you never know

1 Like

If this does not work I guess we should wait for one of our better troubleshooters to take a crack at this. I do not want to suggest anything crazy until they take a look lol.

Hey thanks! I didn't know you could install directly from the terminal, I extracted one from Gnome-Look and put it in the /home/.icons/ directory. Well now I can make it any size I want!

(I like it on the Medium size, so it's not as big as may be expected)
Anyway thanks a lot! I'll make sure to install cursors from the terminal next time!

1 Like

All cursors are not available that way.

But I am very glad it worked :slight_smile:

1 Like

I probably won't need many more cursors. I've been using Oxygen on my desktop for around 2 years, and since this is a newer install on my laptop it probably will stay as DMZ for quite a while.

1 Like

You actually helped me out a bit as well. I liked the interface you had selected as I had never really given it a chance.

I have been messing around with it and like it quite a bit!

We will see if I stick with it but first impressions are very high

I don't have pro, so I use the first couple of interfaces as they're the only ones I have. Switched from Windows 7 (themed like vista) so that's why I chose that one! Anyways glad I let you see that theme option! XD

1 Like

I have moved to "General Help" as you were seeking a solution to a problem,
As the thread is marked "[SOLVED]" can you now mark the post that helped solve the problem, by clicking on the :ballot_box_with_check:Solution flag under the post itself.


For anyone wondering, it wasn't a major issue just an incorrect source. It might not be the same fix for lots of other situations.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.