[solved] Excessive long boot time probably caused by package update. But which one?

I’m still debugging the problem with the excessively slow boot after normal shutdown. See

excessively-slow-boot-after-normal-shutdown-but-not-so-after-forced-power-off

I was able to circumvent the problem by removing the silent parameter from the kernel parameter list, since plymouth seems to be causing the problem.

I was under the impression, this bad behaviour started some time after the installation. So I started all over again today, but this time I did not install all the package udates that are availabe, except from the ones related to firefox. The system behaves fine so far. Next steps would be to update packages in groups, from least likely, to most likely causing the problem.

I need some help in grouping the packages currently available for update. I’ll add the list of packages I think are not related to the problem first. Next is the list of remaining packages of which I would be grateful for hints which ones are related to “plymouth” at boot time, and which ones are more riskless to install.

apt
apt-utils

Need to groups the following packages

accountsservice
base-files

Edit 11.12.2020
I have shrunk the list of packages in the above list. Reason: The culprit, after much installing, removing, reinstalling, with a lot of reboot, shutdown, boot processing, is identified as tlp package. I have tried the recommended version 1.3 from the linrunner repository as well as version 1.1 fom the standard ubuntu repository. Both have the same adverse impact on the boot process.

1 Like

Thanks for posting the resolution.