[SOLVED] Headset microphone doesn't work on Asus x45C

Hi there!
After trying tons of articles and how-tos, I gave up on trying to set up my headset on ZorinOS 16.1 Core.

My laptop is an Asus x45C.

  • Intel sound card ALC270
    My headset is a wired Phillips TAUH201BK/00

Does anyone also struggle with this?

The headset is working perfectly on Windows and smartphones.

When I plug it on my laptop, only the audio works. On Settings -> Sound, on Output Device, I can see the option "Headphones - Built-in Audio".

In the Input Device show "Internal Microphone - Built-in Audio" which is the laptop microphone.

It also show the option "Microphone - Built-in Audio" but the curious thing is this is not the headset microphone. When I set this device and speak near the headset microphone, it doesn't detect any sound, BUT if I poke or speak inside the headset earbud, the system detects a sound coming from the earbud. Crazy like that!

In my /etc/modprobe.d/alsa-base.conf I've tried several options but now it's like that:

options snd-hda-intel model=generic

Some screenshots:
Settings-> Sound

Alsamixer
image
In this last image, you can see alsamixer shows on the top "Item Headphone Mic [Off]" and I don't know why. I don't know how to enable it too.

1 Like

Capture (record) indicates F4 key. What happens when you press F4 function key on keyboard?

Hi swarfendor, thanks for get in contact.

In AlsaMixer, when I press F4, it shows the "Capture" screen like this one bellow:
image

In this picture you can see that the first item is called "Headphone Mic" and it says its "Off", which means that I can set it's levels like the other items next to it.

In your alsamixer. Hit F5 to show All channels.

Some ideas to investigate, (but from experience, sound problems like this can be hit-and-miss to diagnose).

What happens if you increase level on [Headphone M], 2nd from left?

You may also want to play with the [Internel Mic] channel, 5th from left in your screeenshot.

Also.
Can you see a channel [Auto-Mute] ? is that Enabled, if so set it to Disabled.

Hi, Install qasmixer, qashctl, and qasconfig:

In Qasmixer, see if checking Mic Boost and Mic Extra Boost helps.
Having looked at an unpacking video of your headphones, have you tried turning on and off the mic with the switch on one of the cables?

Hi zabadabadoo,

When I hit F5, this is what it showed:


The 3rd item, "Headphone Mic" is still Off. The 4th and 5th items are "Headphone Mic Boost" but it doesn't change anything.

I tried Enable the Auto-mute but I didn't notice any change either. =/
I think the problem is the microphone present in the headphone wasn't detected... so no matter what I change in Alsamixer, it doesn't seen change anything :frowning:

Hi swarfendor,
This is that qasmixer showed


It doesn't show the "Headphone Mic" control too.
Whatever the problem is, its avoiding the system detect the Headset microphone. :frowning:

Hi there!
I tried several tips from different articles and now it's working :partying_face:

STEPS:

Run “sudo hdajackretask”

  • Click on "Show unconnected pins"
  • On "Pin ID x18" - check override and choose "Internal mic"
  • On "Pin ID x19" - check override and choose "not connected"
  • Click on "Apply now" (ignore the error msg)
  • Click on "Install boot override"
  • Exit

Now open file "sudo gedit /etc/modprobe.d/alsa-base.conf"

  • Add the line “options snd-hda-intel model=headset-mic” at the end of the file.
  • Run “sudo alsa force-reload”

That's it. Reboot the system

Now on the Settings-> Sound

  • On Output, set "Headphone - Built-in audio"
  • On Input, set "Internal Microphone - Built-in audio"

To test it, try to blow or poke over the headset mic and see the "Sensibility bar" is detecting the noise.

It worked for me after a lot of hit-and-miss trials.

Thanks for all the patience and help!

3 Likes

Well done for persevering and resolving the issue yourself. Have marked your post as [SOLVED] in case users with same issue looking for resolution. :wink:

1 Like

I put similar problem with front and back panel. Will trying tomorrow.