[SOLVED] HP Pavilion 15z-eh000 With AMD Ryzen 7 4700u and Vega 8


I have bought an HP Pavilion 15z-eh000 with AMD Ryzen 4700u and Vega 8.

When installing Zorin I cannot get the maximum screen resolution nor have I been able to make the Wifi work.

I have followed the steps to the letter and I could not make it work, I also tried to install the AMD Pro Drivers even so everything remains the same (I also damaged the system a couple of times hahahah).

What could you recommend me to do?

Thanks in advance

Resolution: please try https://wiki.ubuntu.com/X/Config/Resolution#Dynamically_testing_different_resolutions
Wifi: please give output of lshw -c network

I was able to solve the resolution with the following method:

open the file

sudo nano /etc/default/grub

find the line


edit 640x480 to your resolution eg: 1920x1080,并remove the #

for example:


Update by the command

sudo update-grub

Then reboot your computer.

sudo reboot

After executing the command sudo lshw -c network

I get the following answer

*-network DISABLED        
       description: Wireless interface
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlo1
       version: 00
       serial: 20:4e:f6:db:f3:67
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtw_pci driverversion=5.4.0-66-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:79 ioport:f000(size=256) memory:fe500000-fe50ffff

Try: sudo ifconfig wlo1 up

sudo: ifconfig: command not found


Try sudo apt install net-tools then again the earlier command.

SIOCSIFFLAGS: Invalid argument

How about ip link set wlo1 up?

With ip link set wlo1 up

RTNETLINK anwers: Operation not permitted

With sudo ip link set wlo1 up

RTNETLINK anwers: Invalid argument

This mentions updating the kernel but yours is already updated.

Not the exact issue as yours but can you indulge me and check if Secure Boot is disabled in BIOS?

Other than that, your Settings → Wifi → uppermost toggle switch is turned on, yes?

Hello again,

After an intense search, I have been able to solve the problem by doing the following method:

Link: PPA for bug-1888647 : You-Sheng Yang

In terminal:

sudo add-apt-repository ppa:vicamo/ppa-1888647


sudo apt-get update



And now the WIFI works fine!!!

Thanks for the help, there is only one problem with the screen brightness adjustment … If I find how to do it then I will make a post and answer the solution.