Solved! I am trying to display my laptop screen using Network Display

The answer lay in me turning off my Screensaver on the HiSense Roku TV. I hope this helps anyone out there.

*vI just solved another thing about Network Display lag. I assured that I have my laptop off battery power and I disable Mouse Acceleration.
-----------------------------------------------------------------------I have Zorin OS 16 Pro. I am a noob as is my name. I attempted first and I got an error and was told I needed a Direct Display device so I bought the MiraScreen Wireless Display Dongle and set it up. I attempted several times to connect through Direct Display as it shows available but consistently gets errors. I attempt two ways through first connecting straight to my HiSense Roku TV and the next way is to the Mirascreen. Each time it gets an error.

I have no idea what is running natively as far as X11 or Wayland and I just learned about those today so I am not up in the details by much.

Details on MiraScreen. Model G7 Plus Ver. 1.10505.52
Details on Hisense Roku TV. Software Version: 10.0.0 build: 4214


Multi-system Cross-platform
Supports multi-system cross-platform (Android, iOS, Windows) and multi-screen interactive features.

Wireless Audio and Video Transmission
Support full HD wireless audio and video transmission, support HDMI 1.3 HD output.

AP Function
Support the wired Internet, with AP function, can be used as a WiFi hotspot.

Wireless Connectivity
Support WiFi IEEE 802.11ac wireless connectivity, and strong anti-jamming capability.

Support the Miracast
IOS 7 or above, Android 4.0 or above, Windows7 or above.

I've also attempted connecting directly through Wifi to the MiraScreen and that just connects to the Wifi of the device only.


Excellent job on solving your connection issue with your screen, as well as the lagging issue you had.

I have a Chromecast which works good with my tablet, but I have never used a Miracast device, so I wouldn't have been much help anyways. The knowledge I have, is how to setup a Google Chromecast with a monitor/tv, and a tablet, using the APP.

As far as the lagging was concerned, power management is always getting in the way of a computers ability to produce full performance. This is the reason why I always disable it.

When it comes to notebooks, I believe in full performance, they use less power then desktops anyways, so it should never be a problem. Again, great job on doing some self solving, you are positively stellar!



Thank you. I also followed your advice about shutting down Power Management and it solved whatever lag left remaining. Now it keeps up!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.