Solved! I can't add users to Samba


I start Samba in a Terminal in Zorin OS 16.3

Here is what happened:

m@i5laptop:~$ sudo su
root@i5laptop:/home/m# samba
root@i5laptop:/home/m# smbpasswd -a i5
New SMB password:
Retype new SMB password:
Failed to add entry for user i5.

Someone has an idea, what went wrong? I tried it several times, always the same result. I choosed to login as root, so no restrictions will cause problems, I thought ...

Do you already have an account in your system for that user?

sudo useradd <username>
sudo passwd <username>

Create an account and provide a password for this user, then proceed with the Samba configuration.

1 Like

Thank you. Thats it. I have to create the user first and then I can add him to Samba. Next time I copy the error message to a searchmachine before I ask here, it's a common mistake in Samba.

It's good to know that the community here is that fast. As my username reveals, I'm back in Linux and I want to dive deeper into the terminalworld and Unix/Linux applications.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.