[SOLVED] Issue with Software Center

I seem to have a bit of an issue with Software Center. On opening it, and trying to search for apps, it doesn't seem to do anything. It just sits there with a constant spinning circle like its trying, but nothing ever loads.

Likewise, when I open the SC first, and click on any of the apps displayed, it tries to load the page but I get the same endless spinning circle.

I tried a reboot and a couple of commands in the Terminal (Sudo Apt Clean & Sudo Apt Update) but nothing seems to be making a difference.

Any ideas?

1 Like

Can you try reinstalling it:

sudo apt install --reinstall gnome-software

1 Like

Gave that a go, now the app seems to have stopped loading completely, as in all I get is a brief spinning circle on the desktop, but then it doesn't even open. Oops.

1 Like

Rebooted the PC and the app has started opening again, but seems to have gone back to the original problem. Endless spinning circle when you try and search for an App.

Its late here with me, so I'll leave it for tonight and come back to it tomorrow if its still a problem :slight_smile:


You can try:

gnome-software refresh


killall gnome-software

sudo apt remove --purge gnome-software

sudo apt clean && sudo apt autoremove

sudo apt install gnome-software

1 Like

I have come back to it today and its working now. Not sure why it stopped working, but it seems to have sorted itself out, whatever was up with it.

Ah well, just glad its working now :smiley:

Thank you for the suggestions, I'll keep those commands noted incase they are needed in the future.


Could have just been some mild net drop.

This topic was automatically closed after 6 days. New replies are no longer allowed.