[Solved] Netgear A8000 WiFi Adaptor Support

I'm running Zorin 16.2 Pro on my system.
I followed this guide to fix the Netgear A8000 wifi adaptor not being supported under stock Zorin. Reddit - Dive into anything
As stated I'm required to upgrade to kernel 5.19 for the adaptor to work. I've upgraded to 6.2.

$ uname -a
Linux praz-MS-7C56 6.2.16-060216-generic #202306051605-Ubuntu SMP PREEMPT_DYNAMIC Mon Jun  5 16:56:06 UTC x86_64 x86_64 x86_64 GNU/Linux

Then as per the attached post:

$ sudo modprobe mt7921u
$ sudo sh -c 'echo 0846 9060 > /sys/bus/usb/drivers/mt7921u/new_id'

The adopter started to work! But when the system wakes up from suspension, it's very unstable with connection constantly dropping. It randomly sometimes stabilises by itself but most of the time requires reboot after which it works perfectly!
Here is some of the debug output:

[17519.956604] wlx6xxxxxxxxxxx: authenticate with xx:xx:xx:xx:xx:1b
[17520.800179] wlx6xxxxxxxxxxx: send auth to xx:xx:xx:xx:xx:1b (try 1/3)
[17520.802016] wlx6xxxxxxxxxxx: authenticated
[17520.804870] wlx6xxxxxxxxxxx: associate with xx:xx:xx:xx:xx:1b (try 1/3)
[17520.808423] wlx6xxxxxxxxxxx: RX AssocResp from xx:xx:xx:xx:xx:1b (capab=0x411 status=0 aid=22)
[17520.947130] wlx6xxxxxxxxxxx: associated
[17521.948239] IPv6: ADDRCONF(NETDEV_CHANGE): wlx6xxxxxxxxxxx: link becomes ready
[17541.738799] wlx9xxxxxxxxxxx: authenticate with xx:xx:xx:xx:xx:1b
[17541.738813] wlx9xxxxxxxxxxx: 80 MHz not supported, disabling VHT
[17542.753098] wlx9xxxxxxxxxxx: send auth to xx:xx:xx:xx:xx:1b (try 1/3)
[17543.777107] wlx9xxxxxxxxxxx: send auth to xx:xx:xx:xx:xx:1b (try 2/3)
[17544.801121] wlx9xxxxxxxxxxx: send auth to xx:xx:xx:xx:xx:1b (try 3/3)
[17544.806765] wlx9xxxxxxxxxxx: authentication with xx:xx:xx:xx:xx:1b timed out
[17559.518959] wlx9xxxxxxxxxxx: authenticate with xx:xx:xx:xx:xx:1d
[17560.545227] wlx9xxxxxxxxxxx: send auth to xx:xx:xx:xx:xx:1d (try 1/3)
[17561.569216] wlx9xxxxxxxxxxx: send auth to xx:xx:xx:xx:xx:1d (try 2/3)
[17562.593221] wlx9xxxxxxxxxxx: send auth to xx:xx:xx:xx:xx:1d (try 3/3)
[17562.593259] wlx9xxxxxxxxxxx: aborting authentication with xx:xx:xx:xx:xx:1d by local choice (Reason: 3=DEAUTH_LEAVING)

What is causing the instability? Why does a reboot fix the issue?

Thanks in advance for any help with this.

Upgrading to kernel 6.3 fixed this issue! Will continue to monitor...

Hi, can you go back to your original post and add [SOLVED] in front of subject title.

Strangely the "edit" symbol has disappeared. Not sure how I would amend it now. Please can you give some guidance? Thanks.

As you have marked a post as the solution and the thread now shows a Solved Checkmark in front of the title, it seems no longer necessary to edit the title.

1 Like

It doesn't show on my smartphone?
Screenshot please Aravisian.

Personally, I believe that we should call smart phones "insect brain phones", instead.

I have edited the title. Hope all are happy with the change.

1 Like

It's easier to see in the heading than having to scroll down and find it has been solved by the OP which does not show up in 'New' Posts!

Well it is easier to access the phone than trailing to the second floor, thus saving energy to moi, and the ludicrous energy charges made for electricity, currently 3x the amount per KWh compared to Gas. I wonder if a gas powered PC could be made?!


Oh, that's why (not)! :rofl:

As most of our electricity comes from gas fired power stations (but that is another story), then that reality is just one step away. :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.