[Solved] - Printers - mind of it's own

Zorin seems to have a mind of it's own with printers. I have several network printers for various different tasks. Zorin automatically adds multiple copies of them, some working, some not, and the one that worked last time I used the computer might not be there this time. And when I re-named a printer, it made the renamed printer a second copy of the printer that didn't even work. Same kind of thing when I need to install a driver for a printer to get full functionality. It seems to become a non working copy, or I think it did work once, but then something changed again. Is there any way I can simply add/install printers and have them stay that way? And not have it automatically add/change anything?


1 Like

Thanks! That seems to have fixed it. Needed to restart the system for it to take effect.
Just for reference for anyone else, here's what I think I figured out was happening. First it would install multiples of some of my printers, I think because it would see each protocol or port the printer had available as a different printer. Usually only one of the multiples would work at all. Then, if I installed a driver for a printer (PPD) or even just renamed a printer, it would decide that it was no longer the same printer and automatically reinstall it with the generic driver/name. For some reason, that also seemed to stop the one that I had either installed a driver for, or renamed to stop working, so I would have to delete and start over again...
Now that I have disabled the automatic adding (as per above) all my printers have worked properly all morning.

Glad this is sorted. Can you please go back to your first post and add [SOLVED] in front of the Subject heading. I had read on another thread of a user picking up a neighbour's printer and this is something to also bear in mind. HP Printers act as an Access Point - so turn wireless off if you have such a printer and can connect via ethernet or have such printers near to the main machine, directly connected via USB.
Could you also please mark my post as the solution. Thanks.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.