[SOLVED] Steam - Disk Write Error on external drive

Hello everyone,
This is my first post in this forum so I hope that everything is right!
I'm completely new to Zorin, but not to Linux (it's been some months that I have decided to move away from Windows).
During the last period I've started moving around and testing different distros, and I've came accross this one which seems to fit all of my needs and I'm pretty happy.
However I'm facing a problem with Steam which is really annoying and might force me to switch, even tho it seems not to be related to the distro itself but to something I have configured badly - but I cannot find out what.
I have multiple disks, this is the blkid:

/dev/nvme0n1p2: UUID="50df6980-5085-4500-8064-c4c1b928d40c" TYPE="ext4" PARTUUID="812623b3-afa4-458a-9600-187a7f475c14"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/nvme0n1p1: UUID="4B31-99F6" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="529d8491-d8f3-4191-aeb7-83bf20230615"
/dev/sda1: LABEL="Big SSD" UUID="ee3d6666-fc4e-48fd-ac70-2922843178be" TYPE="ext4" PARTLABEL="Basic data partition" PARTUUID="504e600d-a810-4369-9368-39bd31d48093"
/dev/sdb1: LABEL="SSD" UUID="bf5ad9c8-cc7c-4787-b215-403c608d6598" TYPE="ext4" PARTUUID="ea4df631-1370-4b58-96ab-dbdda7008820"
/dev/sdc1: LABEL="Hard Disk" UUID="DE1C6E241C6DF843" TYPE="ntfs" PARTUUID="f7b7feb7-01"
/dev/sdd1: LABEL="Big Hard Disk" UUID="986E9FB26E9F87A0" TYPE="ntfs" PARTUUID="f998136b-01"

I want to put my steam games on sda1, so I have put it on fstab with the following:

UUID=ee3d6666-fc4e-48fd-ac70-2922843178be /media/BigSSD ext4 defaults 0 0

This is kinda working, meaning that I can properly see the disk on boot, I'm able to write and read files and so on.
Since I found out that umask does not work for ext4, I did just chmod it on /media:

bl4ckk@bl4ckk:/media$ ls -la
totale 44
drwxr-xr-x   7 root   root    4096 set 10 22:04 .
drwxr-xr-x  20 root   root    4096 set  9 17:53 ..
drwxrwxrwx   1 root   root    4096 set  9 17:16 BigHDD
drwxrwxrwx   4 bl4ckk bl4ckk  4096 set 11 01:28 BigSSD
drwxr-x---+  2 root   root    4096 set 10 22:15 bl4ckk
drwxrwxrwx   1 root   root   20480 set  9 17:16 HDD
drwxr-xr-x   2 root   root    4096 set 10 22:04 SSD

And then I did put the disk path on Steam in order to install the games there:


And steam did create its files once I tested with a random game:

bl4ckk@bl4ckk:/media/BigSSD/Steam$ tree
├── libraryfolder.vdf
└── steamapps
    ├── appmanifest_1817070.acf
    ├── compatdata
    │   └── 1817070
    │       └── pfx
    │           └── drive_c
    │               └── users
    │                   └── steamuser
    │                       └── My Documents
    │                           └── Marvel's Spider-Man Remastered
    │                               └── 76561198033473323
    │                                   ├── slot0-s-manual-0.save
    │                                   ├── slot0-s.save
    │                                   ├── slot0-s.save.backup01
    │                                   ├── slot0-s.save.backup02
    │                                   ├── slot0-s.save.backup03
    │                                   ├── slot0-s.save.backup04
    │                                   ├── slot0-s.save.backup05
    │                                   ├── slot0-s.save.backup06
    │                                   ├── slot0-s.save.backup07
    │                                   ├── slot0-s.save.backup08
    │                                   ├── slot0-s.save.backup09
    │                                   ├── slot0-s.save.backup10
    │                                   └── -userprefs.save
    └── shadercache
        └── 1817070

The problem is that I receive "Disk Write Error" everytime it starts to download the game's files.
I have tested installing the game on the primary drive, and it gets downloaded correctly.
I haven't faced this problem with the previous distro (I don't know if I can tell its name), so at this point I don't know if I messed up something or this is Zorin dependent.

How can I proceed?

Thanks in advance to everyone, let me know if you need other details!

Is Steam install as flatpak or .deb file?

Hi Storm,
thank you for your answer. I have installed it from the software center, the source is flathub so I guess flatpak is the answer

flatpak runs in sandbox, so it have trouble seeing outside/interact itself. Uninstall the flatpak Steam and try with the .deb

sudo apt install steam

I have uninstalled it from the software center but I still can run it from the applications. Can you tell me the proper way to remove it?

If I remember correctly

flatpak uninstall com.valvesoftware.Steam

EDIT: Fixed command error

You got it, I will try with the .deb and will update you asap.
Thanks again for all the support

No problem :slight_smile:
As a rule I use: Only use flatpak if it can't be avoided - always go for .deb if possible. Snap is out of the question.


Man, it worked like a charm!! Infinite thanks to you, this made my day. Thank you thank you!!
(I will surely follow your rules :stuck_out_tongue: )

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.