[SOLVED] USB Tethering not working

Hello, I'm new to Zorin OS, I recently installed it today and I have a major problem. Because of personal issues, I can't really afford a Ethernet cable and I have to use an Android Tablet to connect to the internet, in Windows I was using this method and barely gave me trouble but with Zorin is different. It detects the device and it connects to it but it just keeps showing the loading icon with no internet access whatsoever, I tried with my phone and it works, I have no idea why it doesn't work with my tablet, any suggestions?

I've done a quick search and can only find android phone tethering. However, on an askubuntu post it did reveal a firmware bug in the android device that got fixed allowing tethering to Ubuntu (on which Zorin is based). I would check to see if there are any updates available for your tablet.

1 Like

Tablets are usually behind the phones in Android version. Depending when the fix was released, your tablet may never receive it. You can try rooting it and installing a newer android version.

If you are tethering, try installing Hotspot software on the tablet and connect wirelessly. If you are connecting wirelessly, try connecting the tablet to the laptop by wire.

Another way would be to enable Hotspot on the tablet, connect your phone and tether through your phone, sharing the tablet's internet (disable mobile data if you do this to ensure use of the tablet internet).

1 Like

Thank you for your reply, you were right, my device was missing an update and that's what it gave it trouble, I've already solved it :grin:

1 Like

could you please tell what you did to fix it?
so others with similar problems can use it for reference?

Which is what I suggested in first reply! Update the tablet!

2 Likes

Thank you so much for your reply too!