[solved] WIFI on Asus USB-N10 adapter not working

Installed latest Zorin Core, no problems, everything seemed smooth and this is the most beautiful Linux distro I have ever seen.

However, my cheap Asus USB-N10 Nano B1 wifi-adapter is not working. It has worked on multiple hardware and with Ubuntu, Pop! OS and Linux Mint out of the box.

Now I see in the network settings that my Nokia 6 wifi hotspot is there, but no matter what I try it will not connect. I would have run inxi -Faz but it is not installed and I can't download it without internet connection. Here is what lshw show though:

  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@2:5
       logical name: wlxfc3497323b4c
       serial: fc:34:97:32:3b:4c
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu driverversion=5.13.0-41-generic multicast=yes wireless=unassociated

Any way to fix this without network connection? Any idea what I should try next? If internet is needed, which I assume is a must, then I have to set up ethernet and it could take a day or two for me to get that connected via my other machine.

Thanks in advance!

I managed to connect via ethernet, but would be nice to get wifi to work. Here is the output of my inxi -Faz

user@acerbox:~$ inxi -Faz
System:
  Kernel: 5.13.0-41-generic x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13.0-41-generic 
  root=UUID=27a59f37-5806-4060-affc-10219f1ca022 ro quiet splash 
  vt.handoff=7 
  Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 3.38.2.1 
  Distro: Zorin OS 16.1 base: Ubuntu 20.04 LTS Focal 
Machine:
  Type: Desktop Mobo: Acer model: Aspire X3470 serial: <filter> 
  UEFI: American Megatrends v: P01-A1 date: 08/05/2011 
CPU:
  Topology: Quad Core model: AMD A6-3600 APU with Radeon HD Graphics 
  bits: 64 type: MCP arch: Fusion family: 12 (18) model-id: 1 stepping: N/A 
  microcode: 3000027 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 16768 
  Speed: 802 MHz min/max: 800/2100 MHz boost: enabled Core speeds (MHz): 
  1: 802 2: 937 3: 952 4: 848 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Sumo [Radeon HD 6530D] vendor: Acer Incorporated ALI 
  driver: radeon v: kernel bus ID: 00:01.0 chip ID: 1002:964a 
  Device-2: AMD Turks PRO [Radeon HD 6570/7570/8550] 
  vendor: PC Partner Limited driver: radeon v: kernel bus ID: 01:00.0 
  chip ID: 1002:6759 
  Display: x11 server: X.Org 1.20.13 driver: radeon compositor: gnome-shell 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD SUMO (DRM 2.50.0 / 5.13.0-41-generic LLVM 12.0.0) 
  v: 3.3 Mesa 21.2.6 compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: AMD BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G 
  series] 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 chip ID: 1002:1714 
  Device-2: AMD FCH Azalia vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:14.2 chip ID: 1022:780d 
  Device-3: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aa90 
  Sound Server: ALSA v: k5.13.0-41-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: ASUSTek 802.11n NIC type: USB driver: r8188eu bus ID: 2-5:5 
  chip ID: 0b05:18f0 serial: <filter> 
  IF: wlxfc3497323b4c state: down mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 9.30 GiB (1.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST31000524AS size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: JC45 scheme: GPT 
Partition:
  ID-1: / raw size: 371.88 GiB size: 365.04 GiB (98.16%) 
  used: 9.29 GiB (2.5%) fs: ext4 dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 34.2 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: radeon temp: 25 C device: radeon temp: 46 C 
Info:
  Processes: 223 Uptime: 1h 23m Memory: 5.51 GiB used: 1.58 GiB (28.6%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: N/A Shell: bash v: 5.0.17 
  running in: gnome-terminal inxi: 3.0.38

Naturally I updated everything via ethernet and rebooted and tried to turn the wifi off and on and plug it in and unplug... Any help would be appreciated.

Should be the RTL8188EUS driver...
It should work on the given kernel...
But you may try an older LTS kernel:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Boot into the kernel with esc or tab at the Motherboard splash, then the grub menu > Advanced Options for Zorin and test.
Or you may need a later kernel, even. The liquorix or TuxInvader kernel may work.
Otherwise, you can install the 8188EU kernel manually.

sudo apt -y install dkms build-essential git

git clone GitHub - lwfinger/rtl8188eu: Repository for stand-alone RTL8188EU driver.

Extract the downloaded file and CD terminal into it or right click in the directory and select "Open in terminal"

sudo dkms add ./rtl8188eu

sudo dkms build 8188eu/1.0

sudo dkms install 8188eu/1.0

Thanks for that, I checked my Xubuntu and it's 5.15.0-30-generic kernel and the wireless device says it's driver r8188eu - everything works there and also on Mint and Pop! OS I never had any problem, the cheap Asus wifi dongle always worked straight out of the box.

Will try a different kernel, sounds too difficult for a newbie but what the heck, such a huge disappointment as Zorin seemed like such a polished product, everything else works like a charm.

No, not at at all. Especially if you go the Liqourix or the TuxInvador route. It is literally just as easy as installing Gimp or Popsicle or most any media player.
Since it will be a Higher Kernel version, rebooting will automatically boot into it.

I am actually using the Liqourix kernel 5.17.2, now.

I tried the git route and it says: "fatal: Too many arguments"

Will try a later kernel, sounds scary for a n00b, but here we go...

So I want a later kernel, 5.15 or higher, how exactly do I install it?

My fault... I keep forgetting that the Discourse Forum Format changes posts... It is very annoying...

git clone https://github.com/lwfinger/rtl8188eu.git

All things are scary when you have never done them, often they are easy once you have done it.
Windows OS has multiple kernels, too. They just do not tell you that it is a different kernel, because keeping the user ignorant is a method of control.
For example, using the Windows Tablet edition is a different kernel, since it has different driver requirements.
To install a later kernel on Zorin OS, I recommend the tuxinvader or the Liqourix kernel - which are very easy to install/

TuxInvader

sudo add-apt-repository ppa:tuxinvader/lts-mainline -y

sudo apt update && sudo apt-get install linux-generic-5.17 -y

Liqourix kernel:

sudo add-apt-repository ppa:damentz/liquorix -y

sudo apt update && sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

Thanks again. I like to go the easiest way, whatever happens in life. If one distro does not work for some reason, it is easier to just try another one. Been using these Debian based distros for decades, never ever had need to try different kernels. Like to keep things simple and stable.

Installing tuxinvader does not seem too hard, downloading 661MB of kernel now... for a wifi driver! I have very slow network, so will take a while. Then just reboot and the new kernel will be there just like that?

Yep.

I would find trying another kernel to be a lot easier than trying a Whole Different Distro...

OK, ran the two apt commandments, installed new kernel, rebooted, now inxi says its kernel 5.17.8-051708-generic - turned on wifi and - IT WORKS!

So thank you and the mods can mark this as solved, if that's the custom here.

Yes this was easier than installing a whole new distro. But for example years ago I tried to install Nvidia drivers and kernels on Fedora and that was such a pain that it was simply easier to turn back to Debian. Just my thing.

Feels good to have such an easy fix and everything is now in order. Awesome forum, got the help I needed very fast.

Thank you! :star_struck:

1 Like

I think we have all experienced troublesome installations. On Windows, too. :wink:

Last time I had Windows installed on my personal computer was back in 2002. Been using Linux since then, for 20 years now. That does not make one an expert - I just used whatever works. Tried different things, but always turned back to Debian and now Ubuntu based distros. Simply awesome! Now I have Zorin on my test machine and if I still like it after a few months, it'll replace my Debian on my main machine. To each his own!