[SOLVED] Zorin install doesn’t recognize Mac OS

Hello, I could use some help. I am trying to install Zorin on a mid 2012 Mac Mini. I’m at the step where I want to dual boot and create a partition for Zorin. But it says no OS detected on the computer. I exited and booted normally to ensure my Mac OS still in fact existed. Tried again to install Zorin but same thing happened. So now I tried to manually create a partition but it does not give me the option to resize, as shown in the step by step from this website. What am I doing wrong? Or how do I proceed without wiping out the Mac OS?

To clarify, I can get to the “Use as: do not use partition” window, but the resize box does not appear.

I have no experience with Mac, but is it possible to resize a partittion inside a Mac?

I tried but for some reason, disk utility won’t let me create a partition, only another “volume”. I tried that but the same thing happens… Zorin boot does not recognize any OS on the computer. Wondering if a different distro would be more appropriate?

You could try a non-ubuntu/debian based distro and bleeding edge/rolling distro. I prefer Solus for that, you could try it and see if it reconize it.

Your other issue is your system might be 32-bit:

Welcome to the Forum!

I have found a Video what explains how You install Zorin in a Dual Boot with Mac OS. It is on a Mac not Mac Mini but it shows how You have to partitioning for the Dual Boot:

For Mac, others have in the past suggested using rEFInd to aid installation and boot.
See: Advantages of using rEFInd over default startup manager on a Mac
Also: Grub failling instalation on Old Macbook 4,1 (2008) - #2 by Aravisian

1 Like

I run into this issue when I try to partition. It won't let me partition any of the drives. Hopefully the screenshot appears here.

The Mac won't let me partition any of the drives. See error message in picture.

Hmm ... For me it looks that there is a Problem with the Size. Did You tried different Sizes?

It won’t even let me adjust the size. It’s locked for some reason. Even if I manually enter a number, it defaults back to 1000. Unfortunately I think this more of a Mac problem than Linux. Still searching the web for answers.

Do you have the same Problem when You click of ''Container disk1'' instead of the first Apple HDD entry?

Yes. I tried every one listed there. Same problem for all.

I think I have found the answer!:

https://discussions.apple.com/thread/8501670?sortBy=best

See the solution posted by Sean Calvert

2 Likes

OH MY GOD IT WORKED! Thank you so much, I cannot believe it’s working right now

1 Like

OH MY GOD IT WORKED! Thank you so much, I cannot believe it’s working right now

1 Like

Good that you are fixed. I therefore marked Swarf's post as "Solution" on your behalf.

2 Likes