[SOLVED] ZorinOS is freezing at login. I'm locked out of my OS

I'm locked out of my LUKS encrypted Zorin Core. LUKS lets me enter password & accepts it, but the secondary sudo password freezes. I am using my Zorin Core USB bootdrive right now instead.

Here is what happened, i was trying to change my sudo password to a single digit, rather than something lengthy.
I entered commands suggested by user @Ocka ,
like "sudo passwd -f root" & "sudo passwd -f username."
Link:[I tried to change my password to a one digit character since my drive is already password encrypted with LUKS - #10 by Ocka]

My password never successfully changed,
then without rebooting I followed instructions from github "rebooting gnome-shell in regards to something else (type Alt + F2 and input r in the prompt"

Then i think that really messed things up, and things started to freeze/lock up so I pressed the physical power button & shut everything down, I dont think i was able to press the OS's shutdown button, things were so frozen.
This is what happens when i tried to login again:

Also this is what happens when i do Ctrl Alt F5 & dmesg

When i mount that SSDI using a usb i can still enter in pasword & access it all. & can still see all contents of the Hard drive.Please help, thanks!

It is hard to tell in the video... Are you able to reach the desktop?

@Aravisian , i think if i press Ctrl F1 i can reach the desktop, but when i do i still cant do anything,it asks for password, then approves, then cycles again. This is the closest to the desktop i can get:

I really can only think of some kind of gnupg failure. You were trying to change the password just prior to this...

Also take a look here:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.