Some error about xdg desktop settings, quickgui quickemu

I'm trying to use quickgui which is a quickemu tool. I installed it correctly with all the dependencies but, I couldn't use some buttons on the gui so i launched it from terminal and im getting this error:
Failed to read XDG desktop portal settings: GDBus.Error:org.freedesktop.portal.Error.NotFound: Requested setting not found

I have never used quickgui or quickemu tools.... would you mind providing some screen shots, maybe the --help terminal screen of the command you are attempting to use.

here, there are some numbers but i hope they are not personal.
I can't click those three buttons down there.

You may also be able to find directed help about quickemu on Martin Wimpress' Discord Server (Wimpys World).

Okay i'll try asking there, thanks.

Are you using any alternative window manager or is this a Base Build of Zorin OS?

I customized a lot but honestly I really don't know what window manager I'm using :smiley: how do i check ?

ah... Well, it takes a certain effort to install another window manager on Gnome... Like XFWM4 or i3.

I think if you had done so, you would be well aware of it.

What about Gnome Extensions like Tiling Managers for Gnome? Any of those?

Well I disabled zorin themes and installed gnome tweaks for more customization, here is how those look like, do you think that is causing the error ? or rather not error but a gui bug, because I can't press those 3 buttons, application starts fine :

Everything there looks fine. Gnome Tweaks is quite stable.
Usually, an xdg-desktop-portal error will relate to the Session.

What about Wayland? Are you logging in on Wayland or on Xwindow?


1 Like

Did you follow the steps for installation and set up? In these instructions, do you see any steps that may have been missed?

I vaguely remember using quickemu in the past and got nowhere fast. If you are just requiring decent VM software then I advise virt-manager (virtual machine manager). When it runs VM of Windows it gives the impression of a bare metal install, the graphics are that good but not sufficient to run graphical intensive games. The only bad experience I have had is that Zorin 16.2 does not run the bootloader screen and login screen defaults to 4:3 resolution but once logged in uses default screen resolution as bare metal install of 1920x1080.

In terms of your specific issue this Arch Linux thread may point you in the right direction:

Yes, i reinstalled it again just to be sure and problem is still there.

I know about virt-manager, tried it couple times. This software makes it a lot easier to install and use virtual machines, well if i can't find a solution i'll probably keep using virt-manager. And about the link you posted, I really have no idea about what they are talking about there to be honest, that is bit advanced for me i guess.

They're discussing setting a default application using xdg-mime command as well as other ways to set default applications.

1 Like

A quick update on this;
The O.P. did contact the developer and they have so far a speculative working point that there may be a conflict between Flutter and Gnome. So far, the issue shows up only on Gnome D.E.
The issue is one of Gnome not properly displaying the full size of the window. The buttons are being cut off - leaving only the labels for the buttons visible, which is why clicking on them did nothing.
The "xdg critical warning" is considered harmless.

Hopefully, this will be soon resolved.

1 Like

I learned flutter and fixed it myself :grin:

1 Like

Your screenshot seems to be focused on the padding.
Did you let the dev know to try your solution?

I'll commit it today to the repo.

1 Like