Some games just won't run ... ? Help, please

Need some help, please. In the past, I've bought games from Some of these games have Linux versions that are installable in .sh format. Out of these games, some of them have run perfectly and without delay (after installing them). However, some of the other ones just don't run. They do install properly, but when I double-click on their desktop icons to play, nothing happens. This is perplexing. Any idea on what's going on here? Thanks to those who respond.

There may be different causes for different games - may need to troubleshoot them independently.
Graphics issues or permissions can cause a .sh file to not run properly.
You can list out your graphics:

sudo lshw -C video

Ran the command you provided. The output was as follows:

description: VGA compatible controller
product: Polaris 20 XL [Radeon RX 580 2048SP]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
logical name: /dev/fb0
version: ef
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=amdgpu latency=0 resolution=1920,1080
resources: irq:126 memory:90000000-9fffffff memory:a0000000-a01fffff ioport:4000(size=256) memory:a0200000-a023ffff memory:c0000-dffff

Does this help at all? Everything appears OK, though.

And thank you, too, of course. @Aravisian

Also - I'll try asking over on the GOG forums. Someone may know something.

1 Like

From this, I wouldn't focus on Graphics Issues just yet.

If you can list the troubled games from GOG, maybe we can examine them individually.

1 Like

Sorry for the late response. Life got in the way. One example of a game that won't run is "Lovely Planet." It installs fine, but for whatever reason, it just won't run. Nothing happens at all when I double-click on the launcher icon for the game. Any suggestions on what to do? Thanks. @Aravisian

Can you please locate the path to that game?
Once you have it, replace the example path in the command below and use ldd to list dependencies:

ldd /path/to/game/binary

max@max-B360M-DS3H:~$ ldd /home/gog games/lovely planet/game/lovelyplanet.x86
ldd: /home/gog: No such file or directory
ldd: games/lovely: No such file or directory
ldd: planet/game/lovelyplanet.x86: No such file or directory


I don't know why I was thinking GoG had Linux Games...

It is almost 1am here, I will return to this in the mornin'...

No worries! Thank you, @Aravisian.

I read through this thread and it offers some interesting suggestions (including specifying 32bit or 64bit).

Thank you very much for this. Very interesting. Glad to know I'm not the only one. Also, I tried playing a couple of GOG games using live USBs for other distributions (so to try and troubleshoot the problem), and I had the same result on them (a few examples of distributions I tried are Linux Mint and Ubuntu). So it's not just Zorin.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.