Some Videos Will Not Play

Just had this happen in the last few days ..... some videos will not open and contain this message on the screen .....

I'm using the 4K Video Downloader ..... downloading from YouTube and the file comes in as a .mkv file ....

The following photos show first an example of just 2 of the files which are highlighted bottom left but there are more ..... the first file won't play but the other will ....

The last photo shows the properties of both of them .... I can't find any difference between them .... ?????

1 Like

It looks like a codec issue... you may want to check that you have the codec pack. I forget the command to install them, which will tell you if they are already installed. It's listed in the top x+1 things to do after installing zorin thread.

If they worked before, it's possible that the files are corrupt or even that portion of the drive is.


Gday Frog,
Have you tried " install restricted extras" ?
or maybe try installing VLC, i believe i had a similar issue & haven't looked back since installing VLC,
I use the VLC Zorin pack, there is a flatpak VLC that also plays bluray.
To find the bluray version i had to search " bluray" in the " Software" app.

It maybe that, your pc woke up grumpy :frowning_face:, restart? maybe.


I may have found the problem ..... a wrong choice in media programs .... I was using Videos (program name) .... when I switched to ExMplayer as I didn't want a complicated program just to watch videos as I don't need to edit or do all those fancy things ...

Apparently Videos doesn't have a very good codex support because the videos I could't open before opened now but with sound only no actual video content could be seen ..... or .... the author of the videos chose not to allow his videos to be seen .....

Anyway I downloaded a bunch more from different people and they seemed to work OK now ..... I'm not closing this thread for a bit to make sure the problem is solved .....

Thanks for all the great suggestions .... :+1:

1 Like

This can also happen due to fractional scaling, ( from experience) :smile:

If you run, may help.
sudo apt-get install ubuntu-restricted-extras

ubuntu-restricted-extras is a meta-package that installs:

  • Support for MP3 and unencrypted DVD playback
  • Microsoft TrueType core fonts
  • Flash plugin
  • codecs for common audio and video files

Like if you install VLC, you don't have to use VLC, but the Video Player you use, may access a codec from VLC to help.

I also try not to install things i don't need. :smile:

1 Like

Well it appears I screwed up ..... I tried to run ...... sudo apt-get install ubuntu-restricted-extras ..... and did OK until a full screen message popped up warning me with something about M$ owning something and there was no way to close that warning ..... when I tried it closed the terminal too .....

When I tried the command again this message came up .....


maybe try,
sudo apt install ubuntu-restricted-extras
Close all open app's before installing.

1 Like

That message means that some other Package management is still running.
Software Store or Synaptic or another Terminal...

If you cannot find it, reboot, Frog. Then run the terminal command again.


Something appears to be locked in my other software and updates as I now get this when trying to use the terminal .....

OK will try again by rebooting ..... it seems Zorin was trying to install something and was open in my taskbar .... I didn't see it ..... :sob:

1 Like

Tried to reboot and run the command again but got the same screen as the photo above something in software & updates has it locked out ..... any idea what to look for ..... in here .....

Continued below the highlighted line


1 Like

You will need to kill it, sorry to say.:smiley:


Ok unless you need the Source codes ( uncheck any source codes)
Check the Canconical partners at the top.
And check only the stable or main of the rest.

1 Like

Do I check the Canonical Partners Source Code ...... the only other source code I see checked is Steam's which I use for gaming

1 Like

Well I followed the instructions as best I could and came up with this in the terminal ..... there were no errors .... TG .....

1 Like

Unless you use/change programs by yourself, your just using extra data storage installing source codes & slower updates.
So just "Check" Canonical Partners.


My terminal and Zorin downloads is back to normal now

I don't know who to give credit to for the solution because I followed both Aravisian (with the FOSS website) which I used and the info from Ocka for his help using the Software & Updater information .....

1 Like

I marked Ocka's instructive post on Ubuntu-restricted-extras as the solution as everything after that was dealing with a secondary unrelated problem.


Well one good thing about all this is it scared the you know what outta me so I made a Rescuezilla back up copy of my drive which I hadn't done since Dec 2022 .... :grinning:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.