Sound doesn't work on Acer Gateway NE46Rs laptop

dude, i'm using zorinos lite on my acer gateway NE46Rs laptop
along with windows 7, in windows i can hear audio from my speaker but when i use zorin i cant hear any sound from speaker but when i use headphones i can hear audio, please help me to resolve this issue

Sound troubles on systemd using distros can cover a lot of ground in troubleshooting.
Can you please review the suggestions made in this thread as a starting point:

If you scroll down a bit, you will see a suggestion to enter sudo alsamixer in terminal and check that mute is not enabled (This is most common as it is enabled by default).

I have had my fair share of sound, i.e. no sound from internal speakers, problems In Z15.n Core. I have used Alsamixer (terminal) to fix mine by enabling Loopback. You will find that setting at far right of the Alsamixer sliders. I have no idea what Loopback does, or why it fixed my no sound problem in Z15.3 Core.
I had previously waggled the Zorin Settings>Sound speaker volume sliders vigoursly min-max-min-max and that would trigger something. I would hear a click and sound would then work. I have said before, diagnosing and fixing sound probelms on Zorin do not follow normal logic and rules of physics.

1 Like

thanks dude for ur kind information but when i get into alsamixer and rised the volume of headphones i can hear audio from speaker but when i pulg in and plug out headphone then i cant hear any audio from speaker

Let's try pavucontrol...

sudo apt install pavucontrol

This is for Pulseadio Volume control
Now open pavucontrol


Look at the Output Devices tab.
What does it show as your recognized devices on that tab?

it shows output device is speaker

Siva, on mine it shows two entries. One is for HDMI out, which it shows as present but is useless as my monitors do not have speakers in them.
The second is my Plugged in external Speakers.
You will see three icons on the upper right side of each entry: A Mute icon, a Lock icon and a Default or Star icon. You will want to make sure the mute icon is not checked on. The Lock and Star icons can be checked to on.
If you test with your music player or video player, you should see an equalizer-style bar moving in time with the sound. Do you see that going on- if so, are you still hearing no output?

in output devies i have option speaker and headphones unpluged](
dude i solved this speaker issue.i have seen a youtube video . as per the methods that showned in that video i resolved my problem .i given that video link here for other users. and thank you for you`re kind information and for helping me