Sound not working - Everest Semiconductor ES8336 sound card for AMD

Yeah same,
That amd folder only contains 3 sbin files unlike the intel one on my machine.

Bu you might be one to something, I'll try to dig on amd driver updates on linux, even tough I've reas somewhere that the sound component is called sof because that how it was initialy created and bot because it only contians intel drivers.

But what do i know ? I am just a frustrated guy trying ot get sound working ahaha

1 Like

Oh yeah, I get you for sure; same for me - can't let it defeat you though! :wink:

If you get nowhere - try LMDE 6; might work. I had to boost all output levels to e-lev-en (Spinal Tap joke) to be able to hear anything, just a heads up!

1 Like

I've been reading again on the issue.
Seems like there is some new kernel config available for support to the es8336 on amd soc

I don't know if it's worth going that route

1 Like

That very well may work - as you've got AMD. There are some GPIO configs and kernel quirks in later versions; I do see mine is using quirk 0x02 or something but I didn't set it.

I'm still reading a little more on the AMD / SOF Intel drivers myself, heh..

1 Like

Yup, I'll try to compile the 6.6.6 with that conf flag and I will get back and let you know. Hopefully this will work.
I actually found some ref to Huawei specific laptops referencing that conf with one guy actually saying that he made it work.

Awesome! I think you're getting much closer now, for sure.

Do have to say - my mic doesn't always work, that may or may not be something you experience. It's not a big deal to me though, don't really use the mic as it is. But, does work - have to change the hardware to 'stereo output + digital input' in sound settings. Picks up for a min, then just blanks out again no sound or mic.

(edit removed link) Realized that's the same link that is on the forum posted - whoops!

Also wondering if maybe has something to do with the GPIO config as well.. I have some parameters set but definitely would be different for yours..

May or may not make a difference......

I remember it did not want to work with Z16.. and is on 20.04.. Mint MATE 21.2 and Z17 did work - and they're both 22.04 :thinking:......

I'm wondering if the drivers are for 22.04 and not 20.04 now..

I'm tempted to wipe and install Z16.3 and try again now, with the es8336 stuff...

Done writing the USB, I'm about to install and give it a try... As the famous Sam Jackson once said: "Hold on to your butts!" :grin:

(edit) Ooookay.. Has to be a 22.04 thing, nothing 20.04 works with that card and driver... You could try the 17 Beta out though. I was able to get it working with 17 - and if not, I'd say give Mint MATE or LMDE 6 a shot. MATE had to have manual install, but that driver I posted works perfectly, and LMDE 6 didn't have to install anything, but did have to mess with levels and both OS's. But... 20.04 didn't work - not exactly sure what or why it won't but, just doesn't. It read the card as something else, definitely not the sof-essx8336..

I tried Z16.3 and no luck, also tried mint, ubuntu and elementary : nothing works.
Ithink it's an amd thing (might be intel thing it seems too lol).
I'm going to try the custom kernel with the amd flag. will let you know !

Edit : 6.6.7 seems to at least have it. so we might have a strong begining here ahah

Might be worth mentioning - Mint had to have the 6.2 kernel installed, my bad, from the software updater tool under 'View - Linux Kernels'.. Then loaded the sound driver and worked.. forgot that part.

That's looking promising though - and I believe you're right with the AMD stuff. My machine with that sound card is all Intel; so definitely some differences.

I'm just pretty baffled at the resistance from this card to work :expressionless:

Have read many, many articles about the es8336 being all over the CN market though; usually the cheaper stuff. Not that that's a bad thing - I have tons of cheap stuff that does very, very well!

1 Like

Darn, still not working. I installed the 6.6.7 with the amd es8336 driver.

~$ uname -a
Linux Huawei-Matebook-D16 6.6.7 #1 SMP PREEMPT_DYNAMIC Thu Dec 14 23:39:43 CET 2023 x86_64 x86_64 x86_64 GNU/Linux

It should work in theory, but it didn't...
The card is still not showing, what the heck ?
Yay i got support for huawei hotkeys but not the sound card :rofl: .

sudo dmesg | grep -i /device
[    0.446918] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
[    0.447004] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
[    0.447066] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[    0.496057] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[    3.924606] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:0e/LNXVIDEO:00/input/input4
[    4.255141] input: GXTP7863:00 27C6:01E0 Mouse as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input5
[    4.255379] input: GXTP7863:00 27C6:01E0 Touchpad as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input6
[   11.888487] input: Huawei WMI hotkeys as /devices/platform/huawei-wmi/input/input8
[   12.045831] input: GXTP7863:00 27C6:01E0 Mouse as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input9
[   12.054240] input: GXTP7863:00 27C6:01E0 Touchpad as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input10
[   12.129227] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input12
[   12.129350] input: HD-Audio Generic HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input13
[   12.129481] input: HD-Audio Generic HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input14

This is driving me crazy and the lack of support on the internet just baffles me and I might have to wait a long long time before it getting fixed unfortunately. :face_with_head_bandage:

Yes, this card is used mainly on chinese laptops; mine is a huawei matebook, which means not really cheap - moreover, maybe the best of 30+ laptops i had in my lifetime (including the fruited ones :slight_smile: ).

I was hoping Huawei will get involved to set things up but We might be waiting for a miracle to happen on that side lol.


Aside from internet fixes, have you tried routing sound through your GPU HDMI output with Pavucontrol?

1 Like

And you did try adding options snd_soc_sof_8336 quirk=0x01 to the end of /etc/modprobe.d/alsa-base.conf?

No idea if any of this would help with what you have:

I was thinking if anything the /dev/snd/ might be helpful; maybe? :person_shrugging: heh..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.