Sound not working - Everest Semiconductor ES8336 sound card for AMD

Laptop (Huawei Matebook D16 with the 4600H AMD) showing Dummy output and no sound on speakers or earbuds on Zorin 16.3.

I have tried everything on the internet but nothing seems to work.

Did anyone with same laptop or sound card manage to get it working ?

alsamixer not showing any controllers for my card so looks like card is not recognised...

thank you in advance

1 Like

Can you please post the terminal output of

sudo lshw -C multimedia

1 Like

You're in luck! I got that working with another Ubuntu OS last year.

git clone
cd custom-kernel/ucm/ucm2_latest
sudo cp ./tplg/* /lib/firmware/intel/sof-tplg/
sudo cp sof-jsl.ri /lib/firmware/intel/sof/
sudo cp -r sof-essx8336 /usr/share/alsa/ucm2

Is apparently the new way of getting installed. I have a different machine but same card - the driver and all that I have is in a .deb package and a file; can't seem to find that one I have. If that doesn't get you going, definitely reply back - there are some commands I had to run to get the sound to output to speakers.

I'll just go ahead and put those up, just in case:

amixer cset name='Speaker Switch' on 
amixer cset name='Headphone Playback Volume' 3,3
amixer cset name='Right Headphone Mixer Right DAC Switch' on
amixer cset name='Left Headphone Mixer Left DAC Switch' on 
amixer cset name='DAC Playback Volume' 999,999 
amixer cset name='Headphone Mixer Volume' 999,999

^^ Only if sound doesn't start working after you get the files in the right places - run one at a time. If the first one doesn't do anything, reboot and test sound, if nothing, try the commands above again (amixer ones). But, same files I have - just a different way of doing it I guess.

Even with the drivers installed, the sound is quite.. dim. Very low.. But, use alsamixer to raise the first level, 'Headphones', to 100% and it'll be much louder. I have no idea why this can't be persistent with my machine, but normally have to raise that 'Headphones' level. alsamixer store 0 works for a few reboots, then just doesn't work after that. Just something to keep in mind.

BTW - Do you also have a RealTek 8723du WeeFee chip?? :smirk:

Hey, thank you for taking the time. here you go :

       description: Audio device
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0.1
       bus info: pci@0000:04:00.1
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:105 memory:d03c0000-d03c3fff
       description: Video
       product: HD Camera
       vendor: Azurewave
       physical id: 4
       bus info: usb@3:4
       version: 21.05
       serial: 0001
       capabilities: usb-2.01
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
       description: Multimedia controller
       product: Raven/Raven2/FireFlight/Renoir Audio Processor
       vendor: Advanced Micro Devices, Inc. [AMD]
       physical id: 0.5
       bus info: pci@0000:04:00.5
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list
       configuration: driver=snd_rn_pci_acp3x latency=0
       resources: irq:101 memory:d0380000-d03bffff

Thank you for taking the time.
I already tried installing this specific cistom kernel and it didn't resolve the issue.
I've redone the steps you described and still nothing.
The amixer commands do cnot seem to go through :

$ amixer cset name='Speaker Switch' on 
amixer: Cannot find the given element from control default

Also i do not have realtek wifi card but the intel AX201.

Alright - there's more..

This is a continuance of what I suggested as the 'new way' - the only way for me to share what I have is to G-drive it with a link.. most people are suspicious of that lol ..

BUT - mentions a quirk in the alsaconfig..

Ah! That's what WiFi I'm using in my Asus, weird - the RTL87xx and essx8336 combos are pretty common haha only reason I asked.

1 Like

i don't mind gdrive links :slight_smile:
I am very annoyed with problem so i'll take every shot to get it solved. thank you !
Also i have been trying to compile the 5.19 from SOF to get the driver working - supposedly SOF released firlware druvers with the 5.19 linux but doesn't seem to work. do you know anything about this ?

Well - what I have might not work in the end. The sound driver I have was only needed for stock kernels - the other machine with the ESSX8336 card only likes 6.2 kernels and up. But, as it went for me: stock kernel, no WiFi no sound. Grabbed both drivers - works on stock kernel (this was with Mint MATE). But, if I don't grab any drivers, and just update the kernel - WiFi works! No sound, but internet does work. I had to use the 1.7 SOF driver, downgrade, run the amixer cset commands again - then update the sound driver to 2.0+, and still worked.. weird. . But, before trying what I've got --

The link posted does say, and know from experience messing with it, that those drivers are added in later kernels. For my card, it worked with 6.2 kernels and up - not sure what the most recent one is, but could definitely try a 6.x kernel version:

And if that doesn't immediately work - then I'll work on getting a link to what I've got to try out. And what I've got is sudo dpkg -i *.deb && sudo ./ and it does the downgrade, install, and copy all the files from the folders over to firmware. There are two manual copies to make, but that's all in the Readme.MD - can just copy / paste in terminal.

I know.. it's kind of.. a lot lol I was really bashing my head against the wall with this one myself. I've made 100 copies of the firmware I have so I don't lose it either :joy:

yup definately a lot and definately a problem for me to make zorin a daily driver...
I will try what you suggested and see how it goes, but 5.15 linux in itself seems grandpa old for the hardware i have i'm assuming. might need to switch from zorin to fedora to get cutting edge linux release; which sucks but if we don't get support for this audio card are we supposed to live no-audio eternally lol ? or maybe dualboot windows as i'm doing whihc is not optimal...

Also tried the sof kernel from the sof project which is supposed to work, compiled it and installed it twice and still no sound...
We can blame Windows all we want but at least when we need a missing driver we don't need to go through hell and back to get it working. to each its strong points !

Right - yeah it's a pain without sound, even the beeps and boops lol

I wouldn't discredit just yet - this was an issue with any distro I've used with that card.. pretty common issue, sadly..

But, that's why I mentioned trying a new kernel in general - the other OS's are absolutely going to be 6.x for sure; especially new Debian or Fedora. And should be about what the others are using as well.

I'd give the kernel install a try - if it doesn't work, pretty easy removal. If that doesn't work, I'll share the link - if you even wanna give that a shot; took me months to figure it out.. not sure why lol probably just a 'me' issue :joy:

haha, okey i'll give the 6.2 a try and get back to this thread if i have anything new. thank you for your support !

1 Like

No worries! :sunglasses:

Hey, So tried the 6.2 kernel from the tuxinvader repo. Still not working.

My guess as some people said on the net : the everest card is not loaded correctly at startup and some other card is been loaded instead.

IS there a starightforward way to know what audio card has been loaded and what driver is bneing used ? the usual commands (inxi,...) do not show any ref to the es8883 :face_with_head_bandage:

Screenshot at 2023-12-04 12-59-45

In one of those links there was something about the quirk settings; as you can see with mine is 0x2, there was mention of a 0x1 - might want to try that out.

But, you can check with sudo dmesg | grep -i essx


the thing is, mine does not even appear on dmesg,which leads me to think that it is not mounted on boot for some reason ; some other card is mounted instead ???

Already tried the quirck setting with 00x2 and no luck :confused:

all devices as indicated on dmesg:

[    0.391499] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
[    0.391551] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
[    0.391580] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[    0.528402] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[    0.914634] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:0e/LNXVIDEO:00/input/input4
[    1.077801] input: GXTP7863:00 27C6:01E0 Mouse as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input5
[    1.077917] input: GXTP7863:00 27C6:01E0 Touchpad as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input6
[    3.368224] input: Huawei WMI hotkeys as /devices/platform/huawei-wmi/input/input8
[    3.398621] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input9
[    3.473966] input: HD-Audio Generic HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input10
[    3.598164] input: HD-Audio Generic HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input11
[    3.606517] input: GXTP7863:00 27C6:01E0 Mouse as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input12
[    3.606757] input: GXTP7863:00 27C6:01E0 Touchpad as /devices/platform/AMDI0010:00/i2c-0/i2c-GXTP7863:00/0018:27C6:01E0.0001/input/input13
[    4.504777] input: HD Camera: HD Camera as /devices/pci0000:00/0000:00:08.1/0000:04:00.4/usb3/3-4/3-4:1.0/input/input15

string containing audio in dmesg :

sudo dmesg | grep -i audio
[    0.274743] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    3.384418] snd_hda_intel 0000:04:00.1: Handle vga_switcheroo audio client
[    3.393710] snd_hda_intel 0000:04:00.1: bound 0000:04:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[    3.398621] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input9
[    3.473966] input: HD-Audio Generic HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input10
[    3.598164] input: HD-Audio Generic HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input11

1 Like

Hmm.. Replace 'essx' with 'sof' - like:

sudo dmesg | grep -i sof

That should show anything linked to the SOF firmware being loaded.

FWIW - I did just try my essx8336 drivers with Zorin17 Beta few nights ago, didn't work out too well with a Live boot. I'm in the process of backing up and getting ready to install to see if I can get it working. Probably later tonight, I don't have much to back up - just a slower PC lol

You've got Secure Boot disabled in BIOS? I'm assuming so since WiFi is working, heh.

Do you have any output with alsamixer? That's one I was having issues with on the Live beta - being Live I couldn't make changes and reboot; that would stick (not persistent). I'm going to start playing with it in a bit though.

(edit) Greetings from Zorin 17 Beta! :smile:

And sound did work, I got it running and all.. I'll work on getting that in a zip and link to you to try if you'd like - it is SOF V1.7-1. All I did was make the file executable sudo chmod +x, then run sudo dpkg -i *.deb && sudo ./ - takes like 2 seconds to run, then reboot - if no sound, run the 'amixer cset' commands. I had to run the commands, but did work. I'll post the link in a sec..

Download, extract, also extract the 'es8336-topologies-2' archive - in the, there are two other commands: sudo cp -r sof-essx8336 /usr/share/alsa/ucm2/ - and another one that's not copy / paste, but you can with this: sudo cp -r es8336-topologies-2 /lib/firmware/intel/sof-tplg/ | Then reboot - test, and if no sound, run the 'amixer cset' commands - reboot again, test. Use alsamixer to see levels and info, you may need to adjust some levels.

PS - es8336-topologies-2 might already be extracted.. just a heads up lol

Have two ISST, or Intel Smart Sound Technology, sound cards - two laptops. One doesn't haven an issue, even with the DST Dolby Ultra Hi-Fi whatever it is.

The cheaper one with the Everest chip - took a while. Partly because of hardware support; pretty new. Like, solid working support last year..

A few factors I can conjure - during install, if Windows wasn't 'shutdown', then it will still have control over some busses; one being sound. Only Win10/11, there's something new with it that holds bus control on a reboot, kind of like a hibernation or sleep mode.

That can be broken though - just need to boot a Windows installer, let it finish getting to the main screen - then just shutdown, no reboot. Boot into Zorin / Linux - sound!

Another was the Alsa levels that the driver sets - doesn't activate the speaker control switch to be 'on', so the commands posted dealing with 'cset' will fix that..

It can be frustrating, believe me - took me a few months to get my Everest essx8336 going, but now works without any issue, and much LOUDER than with Windows in control :smirk:

Just waiting to see what needs to be investigated next!

Nice for trying out the 17 Beta ! I'm waiting for the stable to upgrade :smiley:
Yeah I tried the essx883 archive you sent me but it still didn't work.
I think i'm gonna give up lol haven't managed ot get it working :confused:

That's what i don't get, it's the same hardware it should suit all ; Oh well, i tried a lot fo things and it didn't work...

Well.. poo. That's a headache for sure...

Do your HDMI or headphone port work?

This has some stuff on AMD, I didn't really see what though but, I see you've got AMD - mine is an Intel Apollo Lake series chipset. Might be some differences in what needs to be modified - which, I didn't have to modify anything on my side; just the install and commands.

One interesting note - Linux Mint LMDE 6 booted from live with working sound for my 8336 card, first one to ever do so lol that may be something to check out, if you're still wanting to try Linux on that machine :sunglasses: