Sound not working: Sunrise Point-LP HD Audio Card in Toshiba Protege

Trying to setup Zorin (16.3) on my brothers Toshiba Protege X20W-E (i5) laptop, everything is good except the sound, which in Sound Settings shows the signal bars active, but no sound coming through the speakers (bluetooth audio works). Alsamixer settings have auto-mute off, etc. Would be great if this machine would work rather than needing to go buy an HP or Lenovo, etc. Cheers for any suggestions.

Can you please run in terminal

alsactl restore


sudo lshw -C multimedia

and post the results here?


Can you try

rm ~/.config/pulse/*

Reboot and test sound...

If no good, please check pavucontrol (you can install it with sudo apt install pavucontrol if needed) and check your default output for audio?
Is it routing through the HDMI (Graphics) or through Intel Speakers?

  1. No change after the rm ~/.config/pulse/*

  2. pavucontrol, terminal response is "package not available, but is referred to by another package. This may mean is package is missing or is only available from another source" (etc). But it did install yesterday, but have a fresh live USB as tried MXLinux to see if it would work.

  3. Alsamixer lists the card as HDA Intel PCH, and the chip as Realtek ALC255

NB: I am just running off a live USB stick while checking that it will work...

I am getting a 'SGX disabled by bios' output after boot, after selecting 'try Zorin'...

Really should not see this in Zorin OS 16.

apt search pavucontrol
Sorting... Done
Full Text Search... Done

pavucontrol/focal,now 4.0-1build1 amd64 [installed,automatic]
  PulseAudio Volume Control


sudo apt update && sudo apt full-upgrade

Then check pavucontrol.

You can enable Intel Software Guard Extension in your BIOS Settings to get rid of that.

Sorry for the delay in reply. Have gone to Z17 Core, and getting the same results, including that pavucontrol is still not available. I did enable the software guard extension in the BIOS.

Can you please check your Sources in Software & Updates > Other software tab?

Not present and not allowing me to add...

Please Uncheck the option for CDROM:Zorin as this is only supposed to be enabled for specific use cases and repairs.
Once that is done, run

sudo apt update && sudo apt upgrade

then test

sudo apt install pavucontrol

Done... no HDMI listed

HDMI - Are you routing sound through your Graphics - or through the intel soundcard?

No HDMI active as far as I can tell. Only laptop screen connected, says internal speakers...

Can you show

ls /etc/modprode.d

That gives the "cannot access, no such file or directory" response...


sudo ls /etc/modprode.d

Same response...
Screenshot from 2023-12-22 03-37-08

oh wow... I usually always catch my typoes when I create a terminal command in a post.

I am out of form. It is supposed to be modprobe

sudo ls /etc/modprobe.d

I did wonder (for too shorter moment obviously... :slight_smile: ) was...