Sound not working using TV Speakers

I had an old computer with Windows hooked to my TV and it worked fine. I installed Zorin OS17 Core. The video works fine, but I can't get the sound to go through the HDMI. When I go into the Zorin sound settings I have the option to select the HDMI Video and Audio, but still no sound from my TV speakers. Just looking for stereo sound, not surround sound. But silent. I have to hook up outside speakers via headphone jack. Any suggestions?

What soundcard do you have?

So you have some sound outputs working, albeit analogue.

Have you tried another HDMI cable?

Can you open a terminal session and type

alsamixer

In alsamixer hit F6 to list soundcards and check it is there and selected.

then, hit F5 to show all sound channels. Look for any output channels showing as muted [MM]. Selecting the channel using arrow keys and hit M to unmute. If in doubt unmute them all as sometimes channel labels may err from reality.

Consider posting a screenshot of your alsamixer, but make sure channels on right side are showing and not just a stack of arrows pointing to more channels on the right.

HDMI cable was working with my BluRay player. Here is what I found on alsamixer.


image
image

What is shown to You in the Audo Settings? got to Settings>Audio and there to the Output and look please what Options are offered.

I couldn't take a screen shot of the options because the box closed when I clicked on screenshot. Here are the options:

  1. HDMI/DisplayPort-Built-in Audio
  2. Analog Output - USB Audio and HID
  3. Digital Output (S/PDIF) - USB Audio and HID

I tried all three but could not get any sound. I even tried to get audio from TV by plugging in an AV cord and a headphone cord. Still no sound from TV.

Okay, so the HDMI Audio is there ... Could You try PulseAudio Control? Open the Terminal and type sudo apt install pavucontrol

This is a Program for Audio Output and Input.

I followed your instructions. Still no sound from TV speakers. Do I need to do something else?

When You are in PulseAudio how looks it in the Output Tab and the Configuration Tab?

The Output tab shows Port HDMI/DisplayPort (plugged in) at 100%
The Configuration Tab shows Built in Audio Profile Digital Stereo (HDMI) Output

Yes, You must download it. That is the Reason why I wrote the Terminal Command before. Sorry, if it wasn't clear enough. So, open the Terminal and type sudo apt install pavucontrol

This Command installs PulseAudio Control. When it is installed You should find it in the Multimedia Category in the Menu.

When You have opened it, look in the Output Tab:

And the Configuration Tab:


Please don't be irritated by the Language. My System is in german.

German is no problem. Thank you for your help.

1 Like

I put a video/audio on, and I noticed that in the Pulse Audio, under the HDMI, it is showing a fluxuating bar indicating that the sound is working, still no sound from tv speakers. So it looks like the sound signal is not being transfer to the TV. TV not recognized.

1 Like

Okay. Do You have the Possibility to change the HDMI Cable? And/or change the HDMI Port on Your Machine and TV to test if it is on all Ports? Maybe the Cable has a Problem or a HDMI Port.

Another Thing: This USB audio and HID. Could You check on the Configuration Tab when You click on the Dropdown Menu if You have the Option ''Off''. this will trun this Audio Out put off. So it only runs with Your HDMI Output. Look here:

The marked ''Aus'' is the Off Option.

I just checked, and the audio output is off. I also tried a different HDMI cable and port on my TV and computer. Sigh, still no sound. I can use other means for sound such as my Bluetooth speaker, or my old computer speakers. But the TV speakers just don't seem to be working.

Oh, Oh! I got sound!!! When I first checked it the Zorin output device had changed, so I changed it back to HDMI and it worked! Wow!

Thank you so much. It looks like changing the HDMI port and cable worked!!

Thank you again!

3 Likes