Sound not working

so i have a problem with my sound i think on the first install of the os it was fine but on that day i was struggling with it and when i finally got it to install it was late so i slept,my memory is a bit fuzzy
heres my problem im not getting any sound i sent screenshots of what i checked
plz help

Can you please post the terminal output of

sudo apt install inxi && inxi -A


sudo lshw -C multimedia

You needed a space between "inxi" and "-A"

Hmmm... I cannot find much on this hardware. You might try

sudo apt install linux-modules-extra-$(uname -r)

Though I suspect that you already have the modules-extra installed...

Some say to disable Timidity:

sudo systemctl stop timidity.service
sudo systemctl disable timidity.service

You can undo the above with

sudo systemctl enable timidity.service

here's what it says

It was a shot in the dark...

Perhaps @zabadabadoo can be more helpful as he is far more adept at troubleshooting sound issue than I am.

thank you so much though, you already mentioned him so im assuming he's gonna check this right

I now can see a working "Built-in Audio" device alongside with the "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller" that continues to show as deactivated on sound settings / hardware. Selecting Built-in Audio makes my speakers and headphones work.

I don't really understand when I go to the audio mixer it just shows dummy speakers can you send a picture or something plz


sudo -H gedit /etc/default/grub

and add 915.disable_power_well=0 to GRUB_CMDLINE_LINUX_DEFAULT. If you have for example


you'd replace it with

GRUB_CMDLINE_LINUX_DEFAULT="i915.disable_power_well=0 quiet splash"
1 Like

I have had to do some websearches using "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller dummy sound".
This looks like a sound v linux kernel issue.

Not sure if it will be any help, but a Lubuntu user found a solution described here.

See from the above link:
A look at dmesg took me to GitHub - thesofproject/sof-bin: Firmware and topology binaries and solved my problem. I backed up my firmware files, ran the install script and was good to go.

No idea if that is any good to you though. Otherwise maybe try a different kernel. :thinking:

Thanks for the help everyone, I can't seem to get it to work,
Thank You So Much GIF by euphoria

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.