Sound Output Must Be Manually Set Every time

I have to manually set my audio to my headset every time I log in. This includes if my screen times out while I am using it. How do I set my audio output to not change?

sudo apt install pavucontrol

pavucontrol

What output settings are being managed by the PulseAudio controller?

1 Like

I do as well, I couldn't find working fix, so I accepted it as reality. And truth is, with the Sound Output Chooser extension, I can very quickly change it from the taskbar. Maybe Aravisian will find a fix for you.
https://extensions.gnome.org/extension/906/sound-output-device-chooser/

1 Like

Have you tried setting it in Alsamixer (run it from terminal)
then save setting that works with:

sudo alsactl store

Let us know if this works for you. I am more than aware that sound problems and fixes are often trial and error.

1 Like