Sound Selection does not apply

So when I select Output Device as "Digital Output (S/PDIF) - G435 Wireless Gaming Headset" did not apply. When I tested the sound it always came up to speaker. None of Output Devices applying the saves, and I reboot the system multiple times. Any idea?

It worked like 2 - 3 hours ago and now it just don't work anymore

UPDATE: I also tried to use Bluetooth method but that didn't work as well

You should first start by analyzing the problem and running some basic audio configurations.
You can Try alsamixer for now, in order to check if the device is detected and working.

I checked the software and the device is detecting and working

If it worked before, maybe you had a kernel update. If so try Zorin Advanced Options at boot and select to boot a previous kernel.

What soundcard do you have?

Open alsamixer in terminal
Hit [F6] check correct soundcard is used.
Hit [F5] to show All sound channels.
Look at the sound channels, not just headphones, and unmute and increase levels.
See if that helps.
You could also have a play with [Loopback] changing status between enabled or disabled.
Also [Auto-Mute] disabled or enabled.

You could also post a screenshot of your alsamixer for us to check.

1 Like