SoundBlaster G5 Mic not showing/working

Hey all. Got a problem that seems to be a Linux one, not just Zorin but each distro has its own way to "fix" it. When I was using Mint, to make the mic work from my Sound Blaster G5, I had to type this in CLI -

amixer -c 1 sset 'PCM Cature Source' 'External Mic'

Had to do that every time I was going to use the mic for Discord, Zoom, etc. That command doesn't work in Zorin. As I am still pretty new in Linux but try to find solutions to problems, I am not sure how to do the same or even a permanent fix for this issue. Don't understand why Linux, in general, has this problem as it seems to been an issue for over a decade. Not complaining about Zorin, just in Linux as a whole. :slight_smile:

What do I need to do to get my mic working again to use for Zoom meetings and Discord? Thanks!

If you have alsamixer installed use the command amixer to automatically switch the PCM capture source to the Mic.

For me this was: amixer -c 1 sset 'PCM Capture Source' 'External Mic'

Run this at startup by saving as an executable script and adding to Startup applications or by using /etc/init/. -c 1 selects card 1 (the Soundblaster G5 in my case). You can run amixer -c 1 get 'PCM Capture Source' to get the other options like 'What U Hear'. Plus you can also set your appropriate volume/gain etc using alsamixer to save those.

Try this, G5 and G6 using the same steps to work.

1 Like

You may also need to install alsamixer, first.

In terminal run Alsamixer and post a screenshot of All sound channels so we can see what mic seetings may be adrift.

Took me a while to find out to run alsamixer, it needs to be all lower case. No capital A. :slight_smile:

After reinstalling alsamixer using Synaptic, the CLI command works now. BUT, I don't know how to make a executable script to add to startup. I do know how to add to start up, but not how to make EXE scripts. Still very new and slow learning Linux. :slight_smile:

Maybe @Aravisian or @FrenchPress can help you with that.

I just opened up my "auto-start application" (should be included as default in Zorin).
I think you could add alsamixer there along with a command.

For example, the startup sound has this command in entry:
/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

2 Likes

Exactly.

Open a text editor and save the command from your OP in the script. You can name it whatever you want.
You can save it where ever you want, as well, but I recommend in ~/Documents (Your Documents Folder).

Once named and saved, right click it and enter the Permissions tab and ensure it is checkboxed ON to Allow running as Executable.
Open AutoStart and add the script path as the command.

1 Like

Can someone explain why the OP has to do this?
Surely alsamixer (terminal) is part of ZorinOS standard build and can be run on demand.

It would be good if the OP would post a alsamixer screenshot of his settings.

1 Like

This isn't a new problem and have seen people trying to get it patched or fixed for a very old time. It isn't a Zorin problem. It has been a Linux issue. For some reason, no one wants to or can not fix the problem.

Thank you for that help. You wouldn't believe how long I have been asking on other distro forums and rooms for something to work and they would tell me like I have been Linux for years, how to do it. This is after I told them I am very new to learning Linux. But you guys helped me more than anyone where else! Thanks! Now I have this post bookmarked and keeping the TXT file on backup. Just rebooting the machine with that TXT as an executable and in the Startup Programs, it was added and work flawlessly. :smiley:

2 Likes

The community is great here indeed. I used Zorin Core 16 for about a month, after that i switched to Pop! OS 21.04 and yet people are kind enough to help me when i have a problem. I love that, thats why i stay at this great community.

2 Likes

I can see from those Alsamixer screenshots that an External Mic is set Muted [MM].

I am not sure if those screenshots were taken when your mic was working or not, so is that setting intentional?

Did you at any time try un-muting that channel to get your mic working, then store the alsamixer settings with:

sudo alsactl store

Although your problem is solved by running the startup script, I feel that is a work-round rather than a fix. But if your mic now works properly boot after boot, then I am happy for you.

2 Likes

Thanks for the info. Yeah, I did unmute, re-mute then unmute again and no dice. Only after I do the above command, then the mic works. Seems to be a Linux and Sound Blaster not working together. Probably something to do with the device drivers (sort of like the nVidia and Linux issues.) Like I said, it has been a problem for a very long time. And yes, I hate a work around and not an actual fix either.

1 Like