Speaker Audio Cuts Off Randomly

Audio coming from speakers (digital audio) dies out without warning at seemingly random times and I have not found a way to bring it back without restarting. Maybe it might be due to pulseaudio getting confused by the multiple sources?

  • Issue does not happen in Windows installed in a separate partition. The speakers work without any problems.
  • Issue also happens in Fedora 37 installed in a separate partition. In that case the instance is using pipewire-pulseaudio, and the only way to bring back audio was to turn off the audio source and turn it back on in sound settings. This does not work in Zorin.
  • Connecting speakers to motherboard audio (again digital) instead of sound card does not fix the issue. Connecting 3.5mm headphones to the sound card works without any problems. This is currently my backup until I find a solution. (edit: this also has failed after a few hours)
  • Pavucontrol shows audio is being outputted (the sound line moves when audio is played).
  • Restarting pulseaudio with systemctl --user restart pulseaudio does not change anything.

inxi

CPU: 12-Core 12th Gen Intel Core i9-12900KS (-MT MCP-) speed/min/max: 756/800/6700 MHz
Kernel: 5.15.0-57-generic x86_64 Up: 14h 12m Mem: 11169.3/31809.7 MiB (35.1%)
Storage: 21.89 TiB (67.1% used) Procs: 534 Shell: bash 5.0.17 inxi: 3.0.38

inxi -A

Audio: Device-1: Intel driver: snd_hda_intel
Device-2: NVIDIA driver: snd_hda_intel
Device-3: Creative Labs driver: snd_hda_intel
Device-4: ASUSTek USB Audio type: USB driver: hid-generic,snd-usb-audio,usbhid
Sound Server: ALSA v: k5.15.0-57-generic

sudo lshw -C multimedia

 *-multimedia              
       description: Audio device
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0.1
       bus info: pci@0000:01:00.1
       version: a1
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:17 memory:87080000-87083fff
  *-usb:4
       description: Audio device
       product: USB Audio
       vendor: Generic
       physical id: 7
       bus info: usb@1:7
       version: 0.07
       capabilities: usb-2.00 audio-control
       configuration: driver=snd-usb-audio maxpower=100mA speed=480Mbit/s
  *-multimedia
       description: Audio device
       product: Creative Labs
       vendor: Creative Labs
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=snd_hda_intel latency=32 maxlatency=20 mingnt=16
       resources: irq:16 memory:87d04000-87d07fff memory:87d00000-87d03fff
  *-multimedia
       description: Audio device
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 1f.3
       bus info: pci@0000:00:1f.3
       version: 11
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: iomemory:480-47f iomemory:480-47f irq:195 memory:485e218000-485e21bfff memory:485e000000-485e0fffff

An update:

Had the issue happen with headphones as well unfortunately. After happening for the first time it now happens every few minutes.

However I've also found that going to the Configuration tab in pavucontrol and changing the HDA Creative profile to something other than Analog Stereo Output and then back temporarily brings back the audio for the headphones (digital stereo for the speakers of course). So at least I don't have to reboot.

OK, most audio devices, even nVidia HDMI audio, gets listed as Intel. I see you have a soundblaster card. I had similar issues which I resolved via this method:

Gday @liasunfurl , In Pulseaudio , Set them both output & inputs, to.. " Set as Fallback ". see if that stabilizes the issue.
keep us informed :+1:

In my case even my Creative Labs driver was listed as Intel, so a blanket blacklist on Intel would also get rid of it as well. So I had to do something a little differently.

In my /etc/modprobe.d/blacklist.conf file I added

options snd_hda_intel enable=0,0,1,0

Using the device list from the results of inxi -A this seems to have disabled all Intel audio devices other than the Creative Labs driver one. After restarting I do not see any devices other than "HDA Creative" and "USB Audio".

Pavucontrol also displayed a few "speech-dispatcher" programs in the playback tab that caused some warbling when set to the soundcard output device, so I removed them as well with

sudo apt-get remove speech-dispatcher

Due to the nature of my problem I cannot be sure if this fixed it yet. I've had no issues for the past few hours so I'm optimistic.

Well not even 5 minutes after I made this post the issue repeated. The fallback method did not work as well as HDA Creative Digital Stereo (IEC958) was chosen as the fallback at the time. As far as Pavucontrol is concerned nothing is wrong. It still thinks sound is coming out.

I see you have some Intel components on your system. Have you tried installing sof-firmware package?

It may not have anything to do with it, but it's worth a shot to start to diagnose the issue. At worst case now you can remove the unneeded package.

Are there any convenient ways to install it? I've not found any clear instructions on it and the official documentation mentions building the Linux kernel with SOF code, which sounds overkill.

Press CTL + ALT + T to open up a terminal then run sudo apt install firmware-sof-signed or sudo apt install sof-firmware the package can be under a different name on different distributions on arch it was just sof-firmware I'm unsure on the package name on Zorin