SSDfirmware update,crucial mx500,iso not showing unetbootin/startupdiskcreator

Zorin 15.3 64 core
Various machines

I have crucial mx500 ssd`s in all our machines, I was "housekeeping" and noticed a couple have the earlier firmware.
I downloaded the newer firmware zip from here

the first one down the list of two, at that link.

I then extracted the contents (which are an iso, this is intended to be put on a bootable media eg a usb thumbdrive) the machine in question is booted from the thumbdrive via the f12 bios boot selection and the firmware is updated.

The problem is in creating the bootable media.
Neither unetbootin nor startupdisk creator can see the extracted iso even if you "point" them at it.
I tried with 3 different machines with the same result.

If anyone has a few minutes to have a go at downloading that link and trying with startupdiskcreator or unetbootin to check if they can also not see the iso for burning , I would be very grateful please.

I am of the opinion that the downloaded zip and its contents are simply not right, and it would help a great deal if I had confirmation yay or nay from another person please.

Thank You for reading this.

I just tried it in Unetbootin and it worked and wrote the ISO just fine.

Did you ensure the package had fully finished downloading? Did you extract the completed download?

I did and I did.
This was 24hrs ago, I will have another try right now.

1 Like

I had selected / tested on Version M3CR033

Thats the one.Thank You for trying.
I tried again and unetbootin saysScreenshot from 2021-08-17 19-16-43Screenshot from 2021-08-17 19-21-59

Its me, i wasnt including the path to the iso.
All is fine now.
Thanks again

1 Like