Steam and SC-Controller keep disappearing?

I've been using Zorin 16 Beta for about a month now and it's been working pretty well.
I had Steam installed and set up, all worked fine and I made a desktop shortcut for it.
Lately, every time I reboot the shortcut link gets turned into a generic "steam.desktop" and I can't find the program anywhere.
I then have to "re-install" from the .deb, even though it doesn't seem to re-install at all? It just comes back and logs me in automatically afterwards.

Same with the SC-Controller program, it just disappears into thin air.
I've installed Crossover in the meanwhile and that never disappeared at all, so I'm quite puzzled.
Is it purely Steam-related? Is it a weird quirk of the Beta?

Steam save its local .desktop in ~/.local/share/applications, try move the desktop files to systemwide. See if it solve your problem.

First of all, I don't actually know how to move the files to systemwide. I looked around but couldn't find that location.

Perhaps I also wasn't specific enough in my explanation: it's not just the desktop shortcut not working. When I look for Steam with the Zorin search menu in the lower left corner, it doesn't show up at all.
It's like it randomly and completely gets "uprooted" out of my computer and only the broken desktop shortcut remains as proof it was ever there before.

I booted the pc this morning, Steam was still there but SC-Controller was missing (in the Zorin search menu). I then rebooted after getting a small update for Zorin and Steam was still there.

UPDATE: I think I'm starting to see the problem now. This is a fragment of what comes up in my Terminal if I try to install SC-Controller from the repository:

ecommended packages:
The following packages will be REMOVED:
The following NEW packages will be installed:
linux-libc-dev sc-controller steam-devices
0 upgraded, 3 newly installed, 1 to remove and 0 not upgraded.

I guess that explains why Steam would disappear, but what makes SC-Controller disappear? Steam in its own right overwriting SC-Controller again?

How did you install steam and SC?

I installed both from the latest .deb packages.

I just installed Steam from the repository and then tried to install SC-Controller from the repository as well, which gave me this in the Terminal:

Recommended packages:
The following packages will be REMOVED:
steam:i386 steam-launcher
The following NEW packages will be installed:
sc-controller steam-devices
0 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.

Seems like they're always at eachother's throats.

Try Steam .deb from their homepage and see if it solve the dependency hell.
You might want to report this to the Zorins devs.

1 Like

The .deb from their homepage is the one I've been running the last few days from my Downloads folder since Steam kept disappearing, lol.

Apparently I can get SC-Controller as an AppImage which will do the job just fine.
Will still report it because it's a problem that shouldn't exist.

Thanks for the help, Storm.

1 Like