Steam games are lagging

Hi there,
i am new to Zorin (just installed it yesterday).
I set it up like i want now and tried to continue Dysmantled, which i was playing on Solus before. However, the game is completely unplayable. I can pretty much count the frames it is showing. Same with Spelunky 2.
Since the games ran perfectly fine before, and they are really not that hardware needy, i wonder why this could be. I tried different Proton versions and some suggestions from a thread in this forum. Nothing helped.

I hope you can help me, since i really like this distro so far but this problem puts a huge damper on it.


I wonder if Graphics Drivers are responsible. Can you post the output of

sudo lshw -c video

This is the output of the command:
Beschreibung: VGA compatible controller
Produkt: Hawaii PRO [Radeon R9 290/390]
Hersteller: Advanced Micro Devices, Inc. [AMD/ATI]
Physische ID: 0
Bus-Informationen: pci@0000:01:00.0
Version: 00
Breite: 64 bits
Takt: 33MHz
Fähigkeiten: pm pciexpress msi vga_controller bus_master cap_list rom
Konfiguration: driver=radeon latency=0
Ressourcen: irq:32 memory:e0000000-efffffff memory:f0000000-f07fffff ioport:e000(Größe=256) memory:f7e00000-f7e3ffff memory:c0000-dffff

Hawaii PRO [Radeon R9 290/390]....

Please try:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt -y upgrade

Yeah, i don't have the money for an upgrade :
The commands didn't fix it unfortunately, even after a reboot..

That is a software upgrade, nothing to purchase.
You can open terminal with ctrl+alt+t and then copy and paste each highlighted command above, one at a time, into the terminal and then hit "enter" after each.

Yes, i meant no money for an upgrade on my graphics card :smiley:
The commands didn't work, though

1 Like

Best Misunderstanding... Ever...

1 Like

My guess it's kernel regression. Try boot into a previous kernel.

I tried booting with an older kernel version grub offered me. 5.11.0-38-generic
But now the games don't even start up. Dysmantle just closes itself and Spelunky2 give an error box "renderer error creating texture" and "renderer error journal buffer".
Does this happen because my GPU is too old or why do i have such problems running games on Zorin? They ran perfecly on Solus and i heard that the AMD drivers are better supported than the Nvidia ones?

This is a very good question and I suspect - the answer and opinion can vary over time.

Which Nvidia card are you using?

None, i'm using a AMD Radeon R9 290

1 Like

Can you check if there are more up-to-date drivers using the oibaf repo:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

Well, it installed something. But didn't work. The errors in spelunky come now with the current kernel, too. even after reinstalling it...

I am not very well versed in Steam, Proton and the like... I did a quick search:

Maybe some of the gamers on the forum can be more helpful.

ok, with proton 5.0.10 it runs. But the original problem remains: it is laggy af
So none of the fixes helped :frowning:

But a step in the right direction, at least. You got it to run.
I know others have gotten games tuned to run very well.

Sorry I cant help you with.

I tried different games. Pretty much every game that depends on proton will lag, even if i move them to my system SSD.
Any other ideas? Couldn't really find anything on the internet though.
I also tried forcing older versions of proton to dysmantled, with no improvements. Sometimes the whole system crashes, even. I get send back to the login screen and after login have to restart all my programs...
For a distro that claims it works well for games i have a lot of problems with it...

Works without problems with Nvidia cards, so my guess the problem is with AMD card(s).
This is the reason I always buy Nvidia cards, always reliable when it comes to drivers even though they are close source.
Maybe someone with AMD cards can jump in as I have never owned an AMD graphic card, so I can't help you further.