Steam games can't launch with Proton

Hi, so I'm new to the whole Linux and Zorin OS thing, but basically I have a problem. Proton just doesn't work on Steam. I've tried like 5 versions, including Experimental, 9, 8, 7, and 5. I'm trying to run Payday 2, but I've already put and removed the launch option ( WINEDLLOVERRIDES="wsock32=n,b" %command% since I'm running SuperBLT). Can anyone help me? (PS, it also doesn't work with other Proton supported games)

Try login to Xorg as gaming can be (still) troubling with Wayland.
Please give output of

sudo apt install inxi
inxi -Ga

It gave me this
Graphics:
Device-1: NVIDIA GA107M [GeForce RTX 3050 Mobile]
vendor: Acer Incorporated ALI driver: N/A
alternate: nvidiafb, nouveau, nvidia_drm, nvidia pcie: gen: 4
speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:25a2 class-ID: 0300
Device-2: AMD Rembrandt vendor: Acer Incorporated ALI driver: amdgpu
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1
empty: DP-1, DP-2, DP-3, DP-4, DP-5, DP-6, DP-7, DP-8 bus-ID: 74:00.0
chip-ID: 1002:1681 class-ID: 0300
Device-3: Chicony ACER HD User Facing type: USB driver: uvcvideo
bus-ID: 5-1:2 chip-ID: 04f2:b76f class-ID: fe01 serial: 200901010001
Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.1
compositor: gnome-shell v: 43.9 driver: gpu: amdgpu display-ID: 0
Monitor-1: eDP-1 model: BOE Display built: 2022 res: 1920x1080 dpi: 142
gamma: 1.2 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") ratio: 16:9
modes: max: 1920x1080 min: 640x480
OpenGL:
renderer: REMBRANDT (rembrandt LLVM 15.0.7 DRM 3.54 6.5.0-28-generic)
v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2 direct render: Yes

Also I was wrong, it does work with other games (Tried it with The binding of Isaac Flash and it worked perfectly), so the issue really is Payday 2

I guess you have checked https://www.protondb.com/app/218620?device=pc for hints?

You have a AMD/Nvidia combo? A rare breed. Have you make sure that it's the right graphic card running the games?

Also try run the game via terminal, it might spit out some clues.

I'll try that, but how exactly do I run the game in terminal?

steam steam://rungameid/XXXXXX

Where XXXXXX is the number of the game.

It pretty much did the same thing, It launched, and nothing popped up. Here's the terminal:
$ steam steam://rungameid/218620
steam.sh[9277]: Running Steam on zorin 17 64-bit
steam.sh[9277]: STEAM_RUNTIME is enabled automatically
setup.sh[9347]: Steam runtime environment up-to-date!
steam.sh[9277]: Steam client's requirements are satisfied
Steam is already running, exiting (command line was forwarded).

My suggestion is that you post your issue on Paydays 2 forum on Steam - there may be other Linux users that had the same problem/solution - as it's specific to this game.

I'll do that, but thanks for the help!

1 Like

No problem. Would love to help but I don't own that game and chances are those who own the game are hanging out at Steam Forum :slight_smile:

1 Like