Steam Linux + Proton are running the game but no opening

Hey, I'm trying to play GTA SA on Steam Linux with Proton, but when I run the game, it appears as if it is already open, without showing anything on the screen.

In the following short you can see how it behaves

Some things to keep in mind

  • I installed Steam from aptitude, as flatpak would not allow me to select another disk as my primary

  • The games are being installed on another disk.


  • CPU: i7 2600
  • Graphic: Nvidia GTX 750 Ti
  • RAM: 8 gb


  • Kernel: 5.15.0-89-generic

I recently had this exact same issue. In the end, I am not sure what fixed it.

I completely removed and reinstalled Steam (APT, not FLatpak) and I removed and reinstalled the games I was having trouble with.
I completely removed all my configurations in between.

After performing all of that - Everything is now back to working. I never did narrow down what the exact issue was.

It will be my last option in case I have no other solution.

You can start backing up your games (if they are on an extern place you only need to backup save files if you're not using the cloud function in Steam), then uninstalling Steam and then remove .steam from your home folder.

sudo apt install steam
1 Like

I have done this several times but the problem persists

Finally, the solution I found was to use more outdated versions of Proton, such as 4.2, which solved my problem.

To change the version, you must do the following

  1. Go to Steam "Settings".
  2. Go to "Compatibility".
  3. "Run titles with Proton 4.2-9" (or other option)
1 Like

I tried all the proton versions without luck initially. So your mileage may vary applies.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.