Steam login not recognising password

I am running zorin 15 lite on a dell xps 64 bit. Steam installs fine and appears to work. however it says steam password is invalid. interestingly i can reset the steam password and the reset works fine from zorin. and if i use the new password (which i have just reset on zorin) on a different windows pc it works fine. but the steam login on zorin still says its invalid. Steam support suggest using Ubuntu instead, anyone got any ideas ?.

So with me the Steam password is stored without problems.

The only difference I see to your Zorin is that I installed the core and not the lite.

I wouldn’t expect it to be the case but it may have something to do with how you installed it. Try uninstalling and reinstalling using Synaptic.

just a quick update on progress so far. tried the synaptic package manager - no joy still the same issue. next step was to try installing zorin core istead of the lite version. Rather unexpectedly steam does not now run at all so maybe its an issue with dell xps.