Steam not starting (webhelper not responding) gpu hardware acceleration

system info:

  • ziron 17 core 64bit
  • 48 GB of installed ram
  • AMD® Ryzen 7 1700 eight-core processor
  • RTX 2060 (primary) and GTX 1050 Ti nvidia gpus installed using driver 550

I have a new issue that appears when i get on my pc, when i start steam it gives me a error that webhelper.exe not responding it gives me options to restart steam or disable hardware acceleration, doing the latter allows steam to boot, I assume since of my gpus it enables hardware accel on reboot, even last settings has it disabled, does anyone have a solution so i can boot up and steam just starts without issue? may the linux wizards share me thy linux magic?

You might try launching with GPU acceleration disabled.
Set Steam Settings > Interface > Disable GPU

In steam settings it IS disabled I still get the issue

You may need the later Mesa updates:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

Reboot system before launching steam to test.

ran suggested commands had errors of multiple entries(nothing seemed critical), once completed restarted, steam still failed to startup normally, even after selecting the disable hardware acceleration it didn't boot normally had to press the steam icon again then it booted normally, is there like nvidia settings i can change? one thing I saw in my google search that gsync might be a problem...

These can be critical. Multiple configured sources can mean that the apt package management has uncertainty as to which sources to pull from. Remember, it lacks a brain and cannot make a reasoned decision.

Always, always, always keep your sources tidy and clear so that all updates, upgrades and installs are organized and clear.

Well thanks for the clarification but as it stands my os still boots up normally so I don't sweat it I still a novice Linux user and I don't know the more advanced stuff that you do... I do take caution when I do see errors but I took a chance and it worked out except it didn't fix my issue... That's all

When I look at what other people do and work on, I feel like such a complete novice.
I would like to say that as you learn, you feel like a novice less and less. That is not the case, though - it really feels more like swimming in the ocean.

How we learn is when others share what they know.

I am sorry if I sounded like I was admonishing you. More sharing a warning that can help save a headache later.
You are right, most of the time, a warning over a source configured more than once is not a major issue and won't destroy the machine or anything. But, they should be corrected right away.

If your sources are incorrect, and you update or upgrade packages, you may not be getting the full or correct package or dependencies.
This can cause specific software to not work or not work correctly, even if the computer as a whole still works.

As it is, Steam is not working correctly. I think we should fix your sources, then remove and reinstall Steam and see if that helps to resolve the issue.
It may not - and the cause may be something else; But it is a good first step.

Well reinstalling steam is not a impossible thing as my Internet is pretty good and not much installed on it so wouldn't be too much pain. Fixing the dependentacies not sure how I go about that. I prefer not to wreck my os again and go reinstall everything that be roughly two hours to get back to were I was

I did precieve your earlier post as if you were bit high and mighty but I won't hold it against you, the warning was valid...

To fix the "configured multiple times" you can examine the reported configurations from terminal and just remove the duplicates from the sources.list or sources.list.d
Here is a more full guide on [How to] to help navigate the new and unfamiliar:

Once your sources are all clean, launch terminal and run:

sudo apt remove --purge steam

If you are using Flatpak version - I would recommend removing it using the flatpak uninstall command and switching to the .deb package we will install with the command below:
Reinstall steam:

sudo apt update && sudo apt install -y steam

The -y parameter just tells the apt manager to accept a "yes" answer on all dependencies.
Reboot and test Steam.

If it is still not working - Check that you have Proton Experimental Enabled for each title you are trying to run:
Steam > Settings > Compatibility > "Enable Steam Play for supported titles" checked to On.
In each title, right click > Properties > Compatibility > "Force the use of a specific Steam Play compat tool".

1 Like

I used the deb installer form the steam website, I used your commands and followed the instructions in the article you listed, in the software and updates in other software I saw no duplicates except source code ones, I had boot up issues that I was able to resolve and the boot was successful. when i reinstalled via the command i pressed the steam icon and it booted right up but I must reboot to see if this solved my problem. will update once i do that

thought i'm still getting the not responding error box steam still boots just fine, so it must've been bad dependency installs... though the error pops up the issue appears fixed however I have a new unrelated error i saw on bootup I assume my other ssd might be failing (not concerned as I can get a replacement drive pretty easy, )

thank you aravisian, your input helped. cue ff7 fanfare

1 Like