Stop Google Search default

I have gone into Settings and made Firefox and Duck-Duck-Go the defaults. However, the Google Search screen still comes up every time I click on the Firefox icon. How do I get Duck-Duck-Go to come up instead of Google?

Needs to be done in Firefox itself:
Firefox>Settings>Search>Default Search Engine
change it there.

Like @zabadabadoo wrote you have to do it in the Firefox Settings itself. Here a Picture where You can find it. It is in the Search Tab (the 2nd from above):

Setting the defaults doesn't work. You need to click on the 3 bars at upper right, go to Settings, go to Home, then type in in the "Homepage and new windows" window.

1 Like

I think you are talking about the default landing page that comes by default with Firefox, not Firefox' default search engine.