Strange Internet connection issue

Good morning, afternoon or evening people of Zorin OS Forum . I hope you are having a great week :slight_smile:

Today I come to ask for help because a terrible but peculiar problem arose with this distribution.

I lack a USB WiFi adapter so I opted to use my cell phone to provide internet via a shared USB connection. This never presented any problems and worked quite well; until now :frowning:

When I started the computer this morning the connection suddenly stopped working. My first thought was that it was the cell phone or home internet; things I quickly dismissed after briefly browsing it.

Then I noticed something curious. Telegram desktop and the Tor browser were working fine.

I tried deleting the connection profile and creating it again; disabling the firewall and restarting the computer several times. But nothing works, any idea what could be happening?

Does google load if you type this into Opera?

If so that would indicate a DNS issue.

Also do you still have Firefox installed? Does this happen there as well?

Unfortunately it doesn't work, so if it's not a DNS problem, what could be causing this very strange problem? :frowning:

Is it in all web browsers?

The thread above contains several suggestions.

That's right, only the Tor browser and Telegram can connect to the Internet, nothing else. Not even the terminal.

Have you tried switching from ipv6 to ipv4?

I thought about it, but I don't know how to do it. In windows you can find an option easily, but the Gnome configuration menu is very simple.


Unfortunately it did not work, most of the system is still unable to connect to the internet.

I was looking around the web for someone who has had a similar problem and came across a post on the Linux Mint forums. It is in Spanish, but the user describes exactly the same problem I have. Unfortunately he didn't come up with a solution other than reinstalling the whole system from scratch.

1 Like

I believe that you said the same - except that running your updates re-asserted the issue.
I wonder if you could note the updates so we could review the list. That way, you may only need to put an apt mark hold on the offending package.

$ sudo nano /etc/default/grub




GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1" GRUB_CMDLINE_LINUX="ipv6.disable=1"

  1. Run the update-grub command to regenerate the grub.cfg file:

$ sudo update-grub

  1. Reboot the system to disable IPv6 support.

I had downloading problems doing this fixed it idk this might work for u

By any chance can you boot from a live usb and make sure it works there?

If it does the fastest option honestly might be to backup data and reinstall.

Also do you have Timeshift setup by any chance? Maybe could restore it to a previous state?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.