Strange warning on startup

I am getting this strange warning "no server is specified" on my laptop, before the startup logo screen. Can someone tell me why this is showing and how to fix it, if possible.

Do you have more than one OS installed? I ask this after searching for similar issues and found this nugget:

or take a look here:

no, I have only zorin. did a clean install the last weekend. but if I am not wrong, I think I enabled secure boot

Check in your BIOS / UEFI to see if network boot is enabled, and check the boot order... your Zorin OS disk should be first, the network boot should be last and, if possible, disabled.

I checked the BIOS, didn't find anything suspicious. but it doesn't say zorin but ubuntu for the primary boot

Yeah, mine does, too.

With the machine booted, check to see if you've got a line in /etc/default/grub starting with GRUB_THEME=.

If so, comment out that line: #GRUB_THEME=..., run sudo update-grub, then reboot to see if you still get that error.


or, you can set it to the default:
GRUB_THEME=/usr/share/grub/themes/zorin/theme.txt, and see if the error goes away. But I'd try just commenting it first, it may be that your /usr/share/grub/themes/zorin/theme.txt file is corrupted.

If any of the graphics files in that directory are missing or corrupted, let me know, I can attach them, and you can download them and drop them into that directory.

If the theme file is corrupted, you can recreate that file... here's the contents:

# GRUB2 gfxmenu Zorin theme.
# Designed for any resolution between 800x600 and 1600x1200.
#
# Copyright (C) 2016-2021 Zorin OS Technologies Ltd.
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
# of the License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.

# Global Property
title-text: ""
title-color: "#ffffff"
message-color: "#ffffff"
message-bg-color: "#000000"
desktop-image: "background.png"
desktop-color: "#000000"
terminal-left: "0"
terminal-top: "0"
terminal-width: "100%"
terminal-height: "100%"
terminal-border: "0"


# Show the boot menu
+ boot_menu {
		left = 50%-240
		width = 480
		top = 20%
		height = 60%
		item_color = "#ffffff"
		selected_item_color = "#ffffff"
		item_height = 48
		item_padding = 8
		item_spacing = 8
		icon_width = 32
		icon_height = 32
		item_icon_space = 8
		selected_item_pixmap_style= "select_bkg_*.png"
		menu_pixmap_style = "menu_bkg_*.png"
		scrollbar = true
		scrollbar_width = 12
		scrollbar_thumb = "slider_*.png"
}

+ image {
		top = 100%-47
		left = 50%-240
		width = 480
		height = 42
		file = "info.png"
}

# Show a styled horizontal progress bar
+ progress_bar {
		id = "__timeout__"
		left = 0%
		width = 100%
		top = 0
		height = 23
		show_text = false
		text_color = "255, 255, 255"
		text = ""
		bar_style = "progress_bar_*.png"
		highlight_style = "progress_highlight_*.png"
}

After you've either commented the theme line or changed it to the default, run sudo update-grub, then reboot to see if the error recurs.

3 Likes

I will try with the first method, commenting that line. I compared my theme.txt with yours and they're identical.
by the way, what's that file?

commenting the line in the grub file solved my problem

That sets the look and layout of the grub menu... if there's no theme, grub defaults to a very basic look. Some people have experienced the error you're experiencing after installing, then deleting a new grub theme... it somehow borked grub. I was hoping it was as simple as a corrupted file in the theme. Check all the graphics images in that theme directory to be sure they're not corrupt... just try to open them in an image viewer.

Here's the files you should have in that directory:

If you don't have all of those, or they're corrupted, let me know and I'll attach them so you can place them in that directory.

I think one image might be corrupt. I am not sure but it feels like the zorin logo is missing at one point during the startup "splash" screen. I will check the folder.

I checked the images and I don't see any corrupted file.
about the theme.txt file, does 1 empty line at the end matter?

Shouldn't matter, but you never know... my file ends right after the '}', no blank line at the end.

my system seems to not like that file. I replaced mine with yours and the problem comes back. When I comment the grup line then it works. I hope it doesn't affect something else

That means one of the files referenced in the theme file has to be corrupt. Not sure which one, but you might go through and check them all (it might also be that one of them is sitting on a bad drive sector, so check your drive for errors)... the theme file I posted above is the default, I've not changed anything related to the Grub theme.

I found out why this happens. Few days ago I made a question why I don't see the zorin boot menu. This was disabled by default when you encrypt the installation. So, I compared things between my two laptops, one with encryption and one without. There was no differences between the configurations for the theme, no corrupted image. The reason for all this was the encryption. And with the grub menu turned off, this doesn't get someones attention

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.