Streaming choppy video

Hello,

I have a dell inspiron 15-5557, with Zorin OS 16 Core and I have a problem when watching videos in streaming services like Netflix and HBO Max. After some time watching, the video gets choppy, skipping some frames. I use Firefox, but I tried in Brave browser and had the same issue. I watch in fullscreen in notebook or with a TV plugged through HDMI, and in both situations this problem occurs. My notebook hardware and my internet connections are ok, I didn’t have any problems with it before. I would be grateful if somebody could help.

Specifications:

Zorin OS 16 Core 64bits Single boot

Inspiron 15‑5557

6th generation Intel Core i5-62000u cpu @ 2.30GHz x 4

Dual‑channel DDR3L 8 GB (2x4GB)

Integrated Intel HD Graphics 520

Discrete NVIDIA GeForce 930M

SSD SATA KINGSTON A400 480GB

1 Like

May be your DNS settings if using wifi...

Check this out scroll down to DNS section

Things you must do after installing zorin OS 16

2 Likes

The resolution your gpu can process is 4096x2304@60Hz.

So there should be no problem. Perhaps its the HDMI cable. for 4K screen you should use a high speed HDMI cable, the normal cable are not able to process this resolution.

2 Likes

Also, please check Software Updater -> Settings-> Additional Drivers to see what options are listed there and switch to one of the latest proprietary Nvidia drivers if they’re not already selected.

PS - also please check BIOS to see if you have a way to select only one GPU. The option may be called “hybrid graphics” - try disabling that and seeing if your problem goes away.

1 Like

In Software Updater, check source is "Main Server" not a local server.

2 Likes

It's possible his intergrated gpu is the problem. Maybe @Voluntario can see if he can switch it off in the bios so he can take full advantage of the nvidia card.

1 Like

@Bubby, thanks for the suggested tutorial, there are tips I didn't know about. But sadly it is not the DNS. I have and older notebook, a DELL Inspiron 7520, and it is running smothly with the same internet connection.

@dasjdoom, thanks for the suggestion, but the problem occurs with the notebook screen as well. I have an high speed HDMI cable with ethernet (at least is what it says in the cable), and my TV is an old SAMSUNG UN40D5000PG, so I guess the cable is not the problem.

@carmar, I checked and the driver that is installed is NVIDIA driver metapackage - nvidia-driver-470. The system says it is the recommended driver. There are many other options in the Addtional Drivers, I tried to use other drivers, but the problem continued.

About BIOS, I looked for anything similar to "hybrid graphics" and couldn't find it. Looking for it online, it seems DELL doesn't provide this option in their BIOS.

1 Like

@zabadabadoo I changed the source to "Main Server", run the software updater and it reported that everything is up to date.

Can you check if there is a prime setting in the nvidia-x-server settings.

If the nvdia performance mode does not work, try the nvidia on-demand setting

2 Likes

Hi @Michel. Thanks for taking the time. It is set to NVIDIA (Performance Mode), like yours. Any other suggestion? :slightly_frowning_face:

Hi @Voluntario, anytime my friend.

Did you change it from intel to nvidia or whas it set by default ? If you changed it save the config and reboot. If that did not work try nvidia on-demand setting.

The screenshot came from the internet by the way, i have a GTX 1070 :sweat_smile:

3 Likes

It was by default. I changed to NVIDIA (on-demand), saved and rebooted and it seems to be working just fine! Thank you!

1 Like

@Voluntario If you consider Michel's post (#13) offered you the solution, can you go to the ... tool under his post and hit the :ballot_box_with_check: Solution button.
Thanks.

1 Like

He marked 8 hours ago my post as solution but changed it to the post that has no solution after you asked it haha

This post should be marked so other users know what to do.

@Michel your screenshot shows Performance Mode selected, not NVIDIA (on-demand). So although NVIDIA X Server Settings is the right tool, the setting that worked was not the one you illustrated. So think actual solution is combination of those 2 posts. Anyhow I have moved the flag.

PS: I accept the screenshot was from web.

1 Like

I am sorry @zabadabadoo, i fixed my post with all the details included. I misread his post about that he tried my on demand solution :woozy_face:.

1 Like

Are your video card drivers up to date? I know that has caused problems for me in the past. If the issue still pops up you can try some alternative ways to stream your favorite content here are a few of them listed.