Struggling with permissions

I realise that this is a recurring issue that has many questions and answers on various forums, including this one. But I have honestly tried all of the various solutions so far an none of them have worked. I also do not have a full understanding of terminal commands and so I am essentially inputting commands blindly, as other solutions suggest.
The problem; my external drives are locked to read-only, despite being labelled in properties as read and write.
I am the only user and do have administration access, so all the attempts to change permissions don't change anything, yet the files are still read only.
In particular I have an mp3 player that contains an SD card within it, they both mount successfully and I am able to add/delete some files for each temporarily, then at some point whilst transferring the error message appears saying the SD card is read only. How is this possible?
When I check the properties I am still listed as having full permissions.

Examples of solutions that I have tried that haven't worked;

Any help would be much appreciated.

Is it just external storage devices?
How are they conneceted ? USB? Is there a common factor with the error correspnding to the connection method or port?

Also, what File System is the drive formatted in?

Yes they are all USB external storage, but changing port doesn't solve the issue. I'm also using the same ports for usb mouse and keyboard with no issues.

The mp3 player is msdos and so is the Sd card inside it. The mp3 player has it's own firmware so I don't believe I can reformat it to anything I like.
I have also tried putting the SD card into my card reader, but it is still saying it is only read only there despite the permissions showing that I have full access. The mp3 player has it's own internal memory of 8gb, I can copy files to there without issue.

Don't SD cards have a physical switch to toggle read-only mode?

Not sure about that, the card in question is a MicroSD.

Given everything I have read so far, I must wonder if there is a corruption in your permissions as monitored by gpg and sudoers.

It is highly likely that any fault will default to reducing permissions rather than granting them.

In your O.P., you state that you have set permissions multiple times. This really should have worked.
You answered the question about the MP3 player, but not the external drives. It is possible that a different file system may not respond appropriately. If the external drives are say, "NTFS" formatted. This is not common, though.

Other than that; how do you feel about backing up user data and reinstalling Zorin OS?
That may be the most direct and effect method.

Were these drives originally connected to a windows machine? Did you disable windows fast boot in the windows os prior to installing zorin?

I am betting they are locked by windows, for convenience, if they were ever attached to a windows machine on a reboot.

You can find more detailed institutions in how to remove windows fast boot and hibernation in [Before You Install] (Before you install - #2 by 337harvey).

If you no longer have a dual boot or completely wiped windows, you can use a windows 10 live image to remove this configuration, i believe.

So I've checked my external hard-drives again and they seem to be functioning normally i.e. they are readable and writeable.
The issue with my mp3 player and MircoSD card continues.
None of my external drives or mp3 player were originally connected to a windows machine, before Zorin I was using Elemental and before that a Mac, with OSX and I did have this same issue with Elemental, which is why I switched to Zorin! The issue wasn't there to being with when I first used Zorin and has gradually developed over time. How is it possible that I can copy some files to my MircoSD card only for it to change to Read Only after some of the files have transferred?
The MicroSD is formatted to msdos, so I'm going to try and reformat it directly with Zorin and it plugged into the computer with a card reader, rather than through the mp3 player. Will report back...

I've reformatted the SD card using Disks in Zorin. Now it doesn't show in Files, but does show in Disks...

I tried reformatting my SD card with Disks, which appeared to work but the card doesn't show in Files, only in Disks. Then I formatted the card using my old Macbook using disk utility, which read the card as "unformatted". So I formatted, tried it again on my Zorin laptop, where it appeared in Files as normal and showed the permissions as R+W. But when I attempted to copy some files to it I get the error message claiming that the card is Read Only...
Any ideas what is going on here?

Some SD cards have a physical switch on the side of it that locks it in Read Only mode. Please check your SD card for this.

You can try manually mounting the SD card to see if that allows you the user permissions you need.
Insert the card and ensure it is recognized in Disks - even if it is in Read Only.
In terminal, identify the card


Having gotten your card I.D., you can use that for

sudo mkdir /mnt/sdcard

Replace sdbX with your I.D. from above:

sudo mount /dev/sdbX /mnt/sdcard -o uid=1000,gid=1000,umask=022

It's a MicroSD card, so doesn't have a physical switch.
Terminal says "already mounted" when I typed in the commands you've given me.
The card is there in Files and Disks, is claiming to be be R+W, but then acts as a read only when I try to copy to it...

Unmount the card (eject), then run the commands and insert the card.

You are saying it is R+W in the disks application?
Are you moving files from root on your computer?

If it is saying that and you have ownership of the files you are moving, it is more likely a Faulty card or fault in the card reader.
You might try using a can of air to clean out the reader in case debris is blocking proper contact inside the reader slot.
If it is MicroSD, then these often are placed in a dummy SDCard that is placed in the SDCard reader. Is that the case with yours?

Tried commands again like you said, no change.
Disks show the card as mounted, I can't see how to check permissions using Disks, but looking at the properties of the card in Files does still show it as R+W for owner and group.
The card is working fine in my old macbook, as is the reader. The reader is a Sandisk dedicated mircoSD card reader that plugs into my usb.
So if I can read and write with the card on my Macbook then I'm assuming something is going wrong with Zorin on my laptop.

Your logic is sound.

But we run into this: Which is telling to me that the permissions are correct much like you are experiencing by seeing the card working properly on your Macbook.

Is this an external Plug n' Play card reader?
If so, can you list Make and Model? Maybe we need to look at its drivers. This wouldn't be my first suspect; but given all of the above, it is a stumper of an issue.
Secondly, can you verify that the files you are transferring are files owned by you and have rw permissions for your user?

SanDisk MobileMate USB 3.0 Reader SDDR-B531
It is an external plug n' play reader.
The files I'm transferring are definitely owned by me. I have just copied some of them to the mp3 player's own internal memory with no issues. The Mp3 player has a mircoSD card slot, to expand the memory.
I've had this card full of music before (all owned by me) and been able to transfer, edit etc fully using my current Zorin laptop. So it is as if the read only issue has developed over time and is now stuck like this. I'm assuming this is a software issue and can be rectified.

Have you tried using a different USB port for the Reader?

Can you please relay the output of

cat /etc/fstab

Which kernel are you on?

uname -r

Are you willing to test an earlier kernel and see if the issue persists on it?

Output from cat /etc/fstab;

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=ffb294c0-a5d4-48db-880a-e6459edbc657 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=B1E1-CBA2  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
uname -r

I am willing to test an earlier kernel if you walk me through it.
I have tried other usb ports, makes no difference.