Stuck in Grub 2.06 after trying to install Zorin OS 17 on a chromebook

Hello, i tried to install Zorin OS 17 on my chromebook, it supposedly meets the specifications, and the install worked up until it said "unable to install grub in /dev/sda", then saying it was a fatal error. i chose to press ok, then it said installation was finished and to reboot, and it rebooted into grub 2.06
i may sound stupid.
anyways, i cant figure out how to load or find the kernel to try to boot zorin os, even though it said fatal error. how would i go about finding it?
doing something like "ls (hd0,gpt2)/lost+found/ just leads to grub saying absolutely nothing.
please help or give advice, it would be greatly appreciated.

Have you tried running Grub repair from the LiveUSB?

Chromebooks meet the Hardware Specifications; however, Chromebooks also tend to be a rather "locked-down" system to hardware product. Often, even the BIOS settings are more limited.

Installing GnuLinux on a chromebook usually requires some pre-work to sidestep these locks and prepare the hardware to be unlocked and accept a new operating system.
Chromebooks are built to be used with ChromeOS and the product makers had no intention of anyone ever being permitted by them to use a different OS than what they want you to use.

Many Chromebooks are also ARM architecture, not X64. IS yours ARM architecture?
Heres a guide for installing linux on chromebooks

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.