Stuck in Zorin OS install ... HELP.. Creative Sound Blaster AE-7

I am having trouble installing Zorin Pro 17 OS on a new build computer. It has an Aorus motherboard. I have tried Baletcher, Rufus and now Ventoy. In all cases I get the option to install Zorin (I have tried all options regular, safe mode, Nvidia. After the file checks, I get a screen with the Aorus motheboard icon and a Zorin Z that flashes for about a minute. After the flashing, it stays steady on... for hours. Any thoughts?

I should add that I have used 2 different USB sticks.

Have you disabled Fast boot and secure boot in BIOS as well?


Hi Storm, thank you for responding. I had not disabled secure boot. Fast boot was disabled. Sadly, I am getting the same results. I pass all the file checks and then the screen is stuck with the Zorin logo. I appreciate the help. If you have any thoughts, I would greatly appreciate them. I am pretty new to Linux.

Can you gice the full specs of your computer?

Hi Storm,
Again, I am very flattered that you have shown an interest in helping me.
I would be happy to provide the details of my computer build:

Microprocessor - Intel Core i5-13500 Desktop Processor 14 cores

Motherboard - GIGABYTE B760 AORUS Elite AX

Solid state drive - TEAMGROUP MP44 1TB SLC Cache Gen 4x4 M.2 2280 PCIe 4.0 with NVMe Laptop & Desktop & NUC & NAS SSD

RAM - G.SKILL Ripjaws S5 Series (Intel XMP 3.0) DDR5 RAM 32GB (2x16GB)
Blue Ray - LG Electronics WH16NS40 16X Blu-ray/DVD/CD

Sound Card - Creative Sound Blaster AE-7 Hi-Res Internal PCIe Sound Card

No added video card.

How are the USB-Sticks are formatted? FAT32 or different? If it is not FAT32 you should format it to that and try it again.

Will do. Currently they are formatted to ExFAT. I have tried everything but FAT32. I will report back in a couple hours as I have a few other things that need to be done.

1 Like

Have you checked the SHA265 of your downloaded .iso against the published value, before creating a boot USB with it?

1 Like

Hello Zabadabadoo, Thank you for the suggestion. I have checked the SHA265 and it matches. I appreciate the suggestion, unfortunately, I am still stuck.

Hi Ponce-De-Leon, I am having difficulty getting any of the iso applications to allow me to switch to FAT32. I have tried Ventoy, Rufus and Balena Etcher and USB Imager. Ventoy seemed to have the most hope in that it would format my USB to FAT32, but then when I tried to copy the ISO file to it, I got an error stating that there was not enough disc space even though the disc properties showed more than enough space.

1 Like

There has been quite a scandal in USB Sticks that manufacturers were building a certain size USB Stick, but programming it to read as larger. The buyer would not find out unless they exceeded the actual size of the stick. Whicvh many people don't, at least not right away.
I will point out that PNY, SanDisk and other major brands never did this.
But many off-brands did.

Okay ... I have two Ideas but let me ask a couple of Questions first:

What Brand is your Stick?
How much GB's has the Stick?
Do you cleaned the Stick before formated him?
Do You have other Sticks that you could use?
Do You have only a Linux System or do You have the Possibility to use a Windows System?

1 Like

I have used 2 SanDisk USBs. One is 128 GB and the other is 256 GB. I used both with Balena Etcher and Rufus with no memory size issue. The memory issue occurs with using Ventoy which says there is not enough memory. When I use any of the other ISO copying utilities, I have no problem copying the ISO. However, for some reason none of the other utilities allow me to select FAT32.

I do have some news and partial success. I removed the Creative Sound Blaster AE-7 Hi-Res Internal PCIe Sound Card and was able to complete the boot AND load Zorin!! I may be going in the wrong direction, but I am going to try a larger power supply unit. Current build is a Silverstone 550W 80 plus gold. The Ausus motherboard states that it needs 500W to meet expansion requirements. 550 does not supply a lot of margin. I will have a new power supply in before the weekend. I will post results so that everyone has an opportunity to learn from my experience.

I really appreciate all of the help that has been offered to me in this wonderful forum.

That could be because of the Size of the USB-Sticks. FAT32 - as far as I know - isn't available when You have Capacities like You 128 and 256 GB's. It goes mostly only to 32 GB.

Because of your Comment with the Power Supply: What Components does Your PC have that it needs so much Power?

I provided my system specs in a reply to Storm a couple days ago. The motherboard, and Aorus B760 Elite claims that it needs 500 Watts of power. My power supply is a 550 Watt power supply which is about 10% margin. I am worried that it does not have enough margin for a power surge, say at start up. It works pretty good with the sound blaster card removed, but even so, as I was running Zorin and trying to get used to it, there were 2 incidents where the screen went blank for a fraction of a second. I am open to other ideas.

1 Like

You are wise to use a Power Supply with ample margin of wattage output. PSU's used to be the weakest link in PC builds. Computer stores used to stock loads of them as they were more or less regarded as consumables. It is best to go big and run them unstressed and cool than hot and bothered if you want to keep them alive and well.

Oh, Sorry I oversee that. This is interesting. When you realy need more that 500 Watts without an extra Graphics Card ... I think that is pretty much. But when it then works, that's what matters.

I received the new power supply, 750 watts and it runs very cool and silent. It is a nice upgrade... but still the system will not go to boot with the Sound Blaster card installed. I tried moving it to another slot to see if possible there was an issue with the slot. My next thought is to see if I can figure out how to update the BIOS. I am open to other thoughts. I do not think that this is a driver issue because it will not even go to boot mode so it does not even know what operating system or drivers are installed. I will follow up when I have researched updating BIOS.

1 Like

From websearch "Creative Sound Blaster AE-7 Hi-Res Internal PCIe Sound Card Ubuntu 22.04 no boot"

I know its not Ubuntu (or relations), but wonder if it may shine a bit of light on the issue.

EDIT: Also found this:

via this:

1 Like