Stuck on boot - flashing monitor

....and now it's my turn. My wife's PC (Asus H97M-E, Nvidia 750 Ti, Core) wasn't connecting when I ran the updater (including through terminal). So, I rebooted.
Now it flashes the Zorin logo a few times and then blank screen but it keeps flashing on and off. Seems like GPU drivers, no? I tried nomodeset in grub - no luck.
I got to terminal with ctrl+alt+F3 but the monitor keeps flashing and it won't take input except when it flashes on - I can't even get the keys to register unless I catch it when the monitor flashes on which is very difficult.


Dang dude, somebody else on here was dealing with the same kind of thing after an update. I think recent updates are screwing up your systems.

Yes I agree, it does sound GPU driver situation. But, if the system is not even accepting inputs, except at strange times, the system is not stable.

Best advice I can give you, is to enter terminal mode from GRUB menu, and input whatever the code is to roll back the update. It might be related to a kernal update too.

I remember once I got a kernal update on OS 12, and it prevented a signal to be sent to my TV, I had to rollback the kernal update in order to fix it.

Please try rolling back, and let us know how it goes.

That's another thing I forgot to mention. Before I tried nomodeset, I selected the next older kernel during boot - same flashing.

OK, only other thing I can think of, is go back in terminal mode from Grub menu, and type this in...

sudo ubuntu-drivers autoinstall

Restart, and see if it fixes it, once the drivers are installed.

Aravisian is better with Linux then I, and may have better advice, this is the best I can do.

1 Like

Thanks, ST.
Turns out her var/cache/apt/archives - apt cache were filled up. Cleaned out a bit in the recovery menu and now she's booted up. 20 GB root with 17 GB used up after cleaning. Oops.


WOW dude, we were just talking about hard drives that are too small on this forum awhile back, perfect example.

This is why I told that other guy, 60GB should be the bare minimum for running a Linux operating system. I am glad you fixed it in the end though.

OK Carmar, how about a new hard drive? Lets see, I think our moderator deserves nothing less then a 128GB SSD, yes sir! :grin:

LOL. Amen on the drive space but actually it was the moderator being really bad at IT that caused this. When I first setup Z15 on her system, there had been some annoying interplay between the mobo and the GPU that Aravisian+some hardware tinkering had gotten me out of. Which is why I suspected GPU (and of course the flashing would point to it).
Somehow, I don't know how, I have 30 GB root on all of my machines, except hers (20 GB root). It's my screwup - I think I just wasn't paying attention when I installed on her machine.
Incidentally, I forgot about the ubuntu-drivers command until you reminded me. Tried that in the root terminal in recovery and that's how I found that the apt cache was filled up. So, I'm very glad you chimed-in. Thanks.

1 Like

Hey Carmar, that command is one of my favorites on Linux. Because it actually solves 2-issues believe it or not!

First, if a GPU update failed, preventing boot into OS, that command will get you to be able to get back into your computer again.

Second, if you are suffering from the classic, stuck on manually installed driver in additional drivers app, and can't change, that command will restore the drivers list.

Then all you do is restart, and life is good again. Even though your issue was different, glad I was able to help you fix it, in a odd sort of way lol.

I have even smaller Root and Home partitions on my old machine, so I keep a eye on Disk free space like a hawk. I have no problems as a result.
ST is right, we have had a few conversations about partition sizes. It is good to have a apt and journal clean out once in a while, as they build up unnoticed.

Commands for apt cleanup are well advertised on here.

For journal maintenance I use this sequence, one step at a time.

journalctl --disk -usage
journalctl -r

then after visual review:

sudo journalctl --rotate
sudo journalctl --vacuum-size=100M

100M is on the small side, but you can substitute a different threshold value instead.


Thanks, zab. Cleared out almost 2 gigs on her drive with your suggestion. This did force her to get disciplined to backup her files, so that's good too.

1 Like